Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Before you guys close this question as duplicate, I did go through How do I upgrade from 12.10 to 13.04? and nothing solves my problem there.

When I try to upgrade my ubuntu 12.10 installation it says

The software on this computer is up to date.

There are no upgrades available for your system. The upgrade will now be canceled.

Here's a snapshot:

enter image description here

Question: how to fix this issue and upgrade 12.10 to 13.04?


I tried @montazeri's command and cated release file. Here's the output:

enter image description here

share|improve this question
No! it's not. Methods defined there aren't working! I have a weird error – codefreak Jul 3 '13 at 8:00
What happened after you clicked close? Have you tried running the upgrade again? – Oli Jul 10 '13 at 8:39
yes I did try to run again and again. After I clicked close, process just closed. Nothing else... – codefreak Jul 10 '13 at 11:15
How about upgrading from the command line. Try a sudo do-release-upgrade. – Oli Jul 10 '13 at 11:16
Need to go to the Chat room to help. – MathCubes Jul 10 '13 at 13:27

Question here, have you tried looking at the System Settings > Software & Updates information? Specifically on the updates tab, look at the drop-down where it states:

Notify me of a new Ubuntu version:

If it does not say 'For any new version' but instead says anything else, then this would occur.

share|improve this answer

I would first try

cat /etc/lsb-release

and make sure the it prints the version you should be running. Assuming it is, try

sudo apt-get update && apt-get upgrade

to ensure all necessary packages are up to date. Then perform a


from the command line. If that doesn't work try

apt-get dist-upgrade

prior to installing the release upgrade.

share|improve this answer
I already mentioned I tried all this. – codefreak Sep 8 '13 at 14:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.