Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am not new to Ubuntu, but I don"t know what to do with the following:

sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libqt4-declarative : Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.1) but 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 is installed
 libqt4-designer : Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.1) but 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 is installed
 libqt4-help : Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.1) but 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 is installed
 libqt4-opengl : Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.1) but 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 is installed
 libqt4-qt3support : Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.1) but 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 is installed
 libqt4-scripttools : Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.1) but 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 is installed
 libqt4-svg : Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.1) but 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 is installed
 libqtgui4 : Depends: libqt4-declarative (= 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1) but 4:4.8.4+dfsg-0ubuntu9.1 is installed
             Depends: libqtcore4 (= 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1) but 4:4.8.4+dfsg-0ubuntu9.1 is installed
             Breaks: libqtgui4:i386 (!= 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1) but 4:4.8.4+dfsg-0ubuntu9.1 is installed
 libqtgui4:i386 : Breaks: libqtgui4 (!= 4:4.8.4+dfsg-0ubuntu9.1) but 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 is installed
E: Unmet dependencies. Try using -f.

I cannot update or install any packages. Please help, what I should do..

I tried also this:

sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libqtgui4
Suggested packages:
  qt4-qtconfig
The following packages will be upgraded:
  libqtgui4
1 upgraded, 0 newly installed, 0 to remove and 56 not upgraded.
5 not fully installed or removed.
Need to get 0 B/3.992 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 336705 files and directories currently installed.)
Preparing to replace libqtgui4:amd64 4:4.8.4+dfsg-0ubuntu9.1~ubuntu13.04~ppa1 (using .../libqtgui4_4%3a4.8.4+dfsg-0ubuntu9.1_amd64.deb) ...
Unpacking replacement libqtgui4:amd64 ...
dpkg: error processing /var/cache/apt/archives/libqtgui4_4%3a4.8.4+dfsg-0ubuntu9.1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libqtgui4/LGPL_EXCEPTION.txt', which is different from other instances of package libqtgui4:amd64
Errors were encountered while processing:
 /var/cache/apt/archives/libqtgui4_4%3a4.8.4+dfsg-0ubuntu9.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
1  
Please add to your question what happens when you do sudo apt-get -f install –  Jorge Castro Jul 2 '13 at 19:36
    
I have added it above. –  user91170 Jul 3 '13 at 5:38
    
The question has been answered [here][1]. [1]: askubuntu.com/questions/140246/… –  Abhimanyu Jun 15 at 14:00

2 Answers 2

Ubuntu is telling you what to do run 'apt-get -f install' to correct these

Then, from a command promt, type sudo apt-get update this will only update package manager to latest packages. After successful, you should be able to do: sudo apt-get upgrade

share|improve this answer
    
Thank you for a quick response! I have tried: apt-get -f install than sudo apt-get update than sudo apt-get upgrade. Still have the same issue... –  user91170 Jul 3 '13 at 5:36

Sorry I cannot comment, this is not an answer. I have a similar problem now. If you find something, please post it! Thanks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.