Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently installed Ubuntu 13.04, my headset/earplug isn't working on it, sound is produced only through speakers.

What should I do ? I need to make the earphones work. Thanks.

Here is the output of my alsa-info.sh:

And here is the output of my alsamixer:

enter image description here

share|improve this question
1  
Paste the output of this script please: alsa-project.org/alsa-info.sh –  Gx1sptDTDa Jul 2 '13 at 13:05
    
here it is > pastebin.com/hSznC2QA –  Oommen Kuruvilla Jul 2 '13 at 13:58
    
What do you see when you type alsamixer in a terminal; all speakers and headphone controls should be at 100%. The master is your volume control button. –  Gx1sptDTDa Jul 2 '13 at 14:29
    
here it is -> s22.postimg.org/5j4vzv8td/… IT doesnt show headphone centrols at all. –  Oommen Kuruvilla Jul 2 '13 at 14:40
    
try to plug your speakers where you plugged your headphones, and vice versa, is that working? can be hardware related, may be your mother board connectors are with problem on that. –  Aquarius Power Jul 2 '13 at 20:03

2 Answers 2

Depending on where your pulse audio config is you should try removing it and checking if it automatically reconfigures correctly.

I'm on 13.10 so you'd need to do

# cd ~/.config/
# mv pulse/ pulse.bak/

Restart your system and Ubuntu will recreate the pulse config. Test and see if it's working now.

This fixed some issues I was having.

share|improve this answer

Try configuring System Settings ==> Sound ==> Output choose headphones.

share|improve this answer
    
output is chosen as headphones only –  Oommen Kuruvilla Jul 3 '13 at 1:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.