Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded my libcups package to 1.6 in hopes to fix something but I just buggered things up more. So I want to reinstall it to the version on the repository (1.5.3 I think).

I've tried to do a reinstall using

~#: apt-get install --reinstall libcups2

but that tells me it cannot be downloaded so refuses to upgrade.

I can't just do:

~#: apt-get remove libcups2
~#: apt-get install libcups2

as that wants to remove 299 packages along with it. Totaling 668MB so I am hesitant as that will probably take 6 hours to download on my connection.

share|improve this question
    
How did you upgrade libcups? If you have added another repository, make sure that you remove it first and run apt-get update. If you did it manually, try downloading the package manually and installing it via dpkg. –  January Jul 2 '13 at 10:35
    
@January I did it manually –  Lerp Jul 2 '13 at 10:38
    
Hm, now that I think of it -- can you please post the error message from apt-get install --reinstall libcups2? –  January Jul 2 '13 at 10:40
    
Also, try `apt-get install libcups2=1.5.3 –  January Jul 2 '13 at 10:40
    
@January "Reinstallation of libcups2 is not possible, it cannot be downloaded." I will try your command next, I need to get the exact version name though. It's something like 1.5.3_ubuntu –  Lerp Jul 2 '13 at 10:44

1 Answer 1

up vote 1 down vote accepted

OK, this is too long for a comment. First, check the available versions:

apt-cache madison libcups2

In my system (10.04) it gives output like this:

  libcups2 | 1.4.3-1ubuntu1.9 | http://de.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
  libcups2 | 1.4.3-1ubuntu1.9 | http://security.ubuntu.com/ubuntu/ lucid-security/main Packages
  libcups2 |    1.4.3-1 | http://de.archive.ubuntu.com/ubuntu/ lucid/main Packages
      cups |    1.4.3-1 | http://de.archive.ubuntu.com/ubuntu/ lucid/main Sources
      cups | 1.4.3-1ubuntu1.9 | http://de.archive.ubuntu.com/ubuntu/ lucid-updates/main Sources
      cups | 1.4.3-1ubuntu1.9 | http://security.ubuntu.com/ubuntu/ lucid-security/main Sources

If I want to install one particular version, I'd do

apt-get install --reinstall libcups2=1.4.3-1ubuntu1.9

Possibly, you might need the option --purge as well. (beware, this will wipe your slate clean, including any configuration files).

share|improve this answer
    
Yep this worked. I did sudo apt-get install libcups2=1.5.3* because I didn't know how to find the version name. Thanks! –  Lerp Jul 2 '13 at 10:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.