Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have lenovo Z580 laptop and dual-booted my system with windows 8 and ubuntu 13.04. I can connect to internet using windows 8(both wired & wireless) but cannot connect using ubuntu(both). It always shows me that "I am in offline mode"

share|improve this question

marked as duplicate by Luis Alvarado Jul 2 '13 at 16:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
have you installed latest updates? –  dedunumax Jul 2 '13 at 5:44
    
I tried solution and this is the reply: 04:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01) –  user172030 Jul 2 '13 at 15:13
    
@UbuntuUser I recommend seeing this answer askubuntu.com/a/60395/7035 Take it easy, read carefully and you should have a working Wireless card in no time. The one you have is the same one I have. –  Luis Alvarado Jul 2 '13 at 16:39
add comment

1 Answer 1

It looks like your laptop might use the infamous Broadcom chipset 14e4:4727, which needs special attention.

From http://ubuntuforums.org/showthread.php?t=2092561,

Try running

lspci -nn | grep 0280

If your device is the Broadcom 14e4:4727, then run

sudo apt-get install --reinstall bcmwl-kernel-source

To re-install the drivers. Then reboot and try the connection again.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.