Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having problems when I attempt to install Ubuntu with the Windows Installer "Wubi". I am able to download the installer and begin the installation process. However, before the installation can complete, the following error message pops up:

"An error occured.

Extraction failed with code: 2

For more information, please see the log file: c:\users\djdm\appdata\local\temp\wubi-12.04-rev272.log"

I don't know how to locate this log file (I can't find the "appdata" directory in my computer) and I wouldn't know what to do after I found it. Please help.

share|improve this question
    
copy c:\users\djdm\appdata\local\temp\wubi-12.04-rev272.log into the address bar of windows explorer and copy the contents to your question. What version of windows are you running? –  leszakk Jul 1 '13 at 23:49
    
Extraction usually fails due to an incomplete download of the Wubi disk image. You can't navigate step-by-step to the log file because some of the directories are hidden by default. Either unhide them or you can use a shortcut environment variable:%TEMP%... so you can open Notepad, and then File,Open %TEMP%\wubi-12.04-rev272.log –  bcbc Jul 2 '13 at 5:26
    
@leszakk and bcbc: I copied "c:\users\djdm\appdata\local\temp\wubi-12.04-rev272.log" into my address bar. I also tried using the shortcut environment variable "%TEMP%" in Notepad. They both returned the same thing, which I'm guessing is the installation summary. I'm now wondering how to use this information to solve my problem. I appreciate your input and patience with me, fellas. –  Johann Jul 3 '13 at 15:55
    
Look at this: bugs.launchpad.net/wubi/+bug/1030631 Then scan your log file to see if you have the same problem. I'm guessing you do. If so, add it as an answer and accept it. The fix is to try again (maybe the internet will be kinder) or to download the tar.xz file yourself, but I'd do this as a last resort. –  bcbc Jul 3 '13 at 19:22
    
It worked. Thank you. –  Johann Jul 11 '13 at 19:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.