Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had two partitions with Win 7 and one partition with Kali Linux (Debian). Everything was working great but I got into Android Dev, specifically ROM dev and along the way I figured there was more support on Ubuntu for Android dev.

I decided to reduce some redundancy as I had many of the same apps on both Win 7's and the OS on C:/ (the original with ACER) was a bit screwy due to my insatiable curiosity. I decided to Install Ubuntu 12 on C:/ instead, so I have C:/, G:/ and Kali, Ubuntu is already installed on C:/ all the OS's are there but something happened to my MBR.

When I try to boot up it runs a few lines and the tries a network boot (last option in Bios) first HDD then USBs and then Network is the order I have it now, it was USB first the HDD then Network. Then it jumps to a black screen and says "Operating System not found"

I am sure this is a common problem, I tried to reinstall Ubuntu with several different setup options while being careful not to overwrite the other two OS's.

I think GRUB tried to take over my MBR. I used to be able to boot up and choose to boot either one of the Win 7's or Kali and when I chose Kali it would boot GRUB2, so I had MBR to boot into windows or Kali and if I choose Kali MBR would boot GRUB2 to boot into Kali.

Any Advice would be great, my last option is to back up my Media and settings then to reinstall everything from scratch which would probably take a week to accomplish with my schedule.

share|improve this question
up vote 0 down vote accepted

Try following this guide for using boot-repair

share|improve this answer
Should I reinstall GRUB or restore MBR? – Edge-Case Jul 2 '13 at 0:08
try reinstalling GRUB – leszakk Jul 2 '13 at 0:09
I.followed.the reccomended process and got a black screen that starts with * Stopping System.V runlevel compatibility. keyboard gives no response, esc does nothing, im stuck. reboot? would have to be a hard shutdown. – Edge-Case Jul 2 '13 at 0:41
try "ctrl+alt+F6"? – leszakk Jul 2 '13 at 0:53
this isnt what I wanted but ok. I went ahead and shutdown the system. srry I got impatient. well to my surprise it booted into gtub with all 3 OSs and their recovery modes. I prefer to keep the MBR the was for an added layer of protection against my own dumba** but I'll take it. Grub now works but it did overwrite the mbr. at least as far as I understand the boot process, barely. Thsnk You very much for ur time. – Edge-Case Jul 2 '13 at 0:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.