Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to Ubuntu 12.10 from 12.04. But I cannot use WebApps. In fact there is no sign of them anywhere. Firefox and Chromium are not prompting for integration.

I tried re-installing both browsers/webapps plugin of each, but no luck. Out of curiosity, I tried to install unity-webapps-preview through terminal, apt-get reported that this operation is going to need 127mb. After installation, restarting session, nothing.

I re-ran the unity-webapp-preview in terminal and SURPRISINGLY it again asked me that this operation is going to need 58mb. After Installation, nothing.

Firefox is showing the unity-webapp plugin in Extensions but in Preferences there is noting like Unity settings or options for exceptions in General tab (as I seen in some threads).

Chromium is not even showing the plugin in Extensions nor in the settings. Really need help. I know there is a reported bug but it is mostly about the complains that the webapps are not working as they should but in my case they don't seem to exist.

EDIT: The out put of gsettings list-recursively | grep webapp is:

com.canonical.unity.webapps allowed-domains @as [] com.canonical.unity.webapps dontask-domains @as [] com.canonical.unity.webapps index-update-time 43200 com.canonical.unity.webapps integration-allowed true com.canonical.unity.webapps preauthorized-domains ['amazon.ca', 'amazon.cn', 'amazon.com', 'amazon.co.uk', 'amazon.de', 'amazon.es', 'amazon.fr', 'amazon.it', 'www.amazon.ca', 'www.amazon.cn', 'www.amazon.com', 'www.amazon.co.uk', 'www.amazon.de', 'www.amazon.es', 'www.amazon.fr', 'www.amazon.it', 'one.ubuntu.com']  
share|improve this question

closed as off-topic by bain, Mateo_, Eric Carvalho, Jorge Castro, Radu Rădeanu Jul 14 at 18:18

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Mateo_, Jorge Castro, Radu Rădeanu
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What do you mean by re-ran the unity-webapps-preview? Please edit your question to include the output of gsettings list-recursively | grep webapp. –  edwin Jul 1 '13 at 19:26
    
Welcome to Ask Ubuntu! You seem to be using two different accounts. Please use the contact us link at the bottom of this page to ask for them to be merged. Thanks. –  guntbert Jul 1 '13 at 20:14
    
Can you please add the output of dpkg --get-selections | grep webapps as well? Thanks :) –  Seth Jul 1 '13 at 22:38
    
downgraded to 12.04 from 12.10? upgraded to 13.04 from 12.10? Typo. Please clarify. –  Yet Another User Dec 17 '13 at 21:37

2 Answers 2

The latest version for Ubuntu (stable) is 13.10 and not 12.10, do a clean install to that version and post your feedback, remember to do a backup of your data.

share|improve this answer

I use Trusty, so I cant test this solution, but I found this PPA for webapp integration for Quantal(12.10) https://launchpad.net/~webapps/+archive/preview

Visit this link, and select on "View package details" and find and download integration packages for your browser, and then install "unity-webapps-2.0-0quantal1" (or you may do this first before downloading integration packages for your browser)

Hope this works.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.