Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently i had added a 2GB DDR3 ram in my acer laptop. As a result my total ram is 4GB (2x2). I was running ubuntu 12.04 32bit(pae kernel). Everything was working fine. Now i have upgraded (new install) to 13.04 64bit. Suddenly i noticed that system is showing only 1.7GB. So i run lshw to ensure the fact. But lshw shows correct result (4GB = 2x2). How could i solve this??? There is no settings in BIOS for ram at all. My system is newly installed. No additional applications is installed except amd-catalyst driver.

System:

Acer aspire 4250 E-450 apu

enter image description here

enter image description here

Note: BISO also showing that 4GB ram installed.

share|improve this question

3 Answers 3

that is very strange. This question has some suggestions.RAM upgrade installation which may be worth looking at. It looks like Ubuntu only reports the ram which isn't given out to hardware e.g graphics cards.http://ubuntuforums.org/showthread.php?t=1452306

share|improve this answer
    
thanks for quick reply. First link doesn't sense for this issue. I had already mentioned that i am using 64bit system. Second issue is doubtable. But i checked. I have un-installed graphics driver but no luck. –  shantanu Jul 1 '13 at 19:52

I'm going to take a stab at this. Since you have an APU, I would go into the BIOS, and make sure that the video card is not using the missing RAM.

To find out how much ram the video card is using, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo dmesg | grep drm

or you can install System Info

sudo apt-get install sysinfo
share|improve this answer
    
thanks for your reply. sysinfo is showing 1.7GB ram, and here is the output of dmesg. pastebin.com/vzxcZ2GT VRAM is showing 256MB in BIOS –  shantanu Jul 2 '13 at 3:20
    
Can tell me more info about the RAM that you added? manufacturer, and model number? –  Mitch Jul 2 '13 at 4:16
    
transcend ram (2GB, 1330MHZ). I had already used it for 1 month in ubuntu 12.04. But notice this problem once in ubuntu 13.04 (64bit). Sorry i don't know the model number. –  shantanu Jul 2 '13 at 8:50
1  
Try removing it, clean the contacts with an eraser, and put it back in. Make sure that it click good in place. –  Mitch Jul 2 '13 at 8:52
up vote 0 down vote accepted

I have solved my problem by cleaning the ram modules. But i don't understand that why lshw was showing 4gb ram.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.