Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Modem called TP-LINK TD-8817 USB

The problem Who when I log to ubuntu the modem don't run but if I want to run it I should remove the wire of the modem and enter it again

I have to do this every-time I want to run the Internet.

share|improve this question
add comment

1 Answer 1

Your TD-8817 modem can also be connected with the Ethernet network adapter of your PC. See also this answer on DSL connections. It is best advice to do so as connecting by USB can only be done with (usually proprietary) drivers and network needs to be bridged to the USB driver. The problem you encounter may likely come from the USB driver that only allows you to connect after re-plugging your device.

For your modem use this socket to connect with an Ethernet cat5 patch cable to the LAN port on your computer:

enter image description here

Once your modem is connected with the Ethernet port all traffic can be handled by default Ubuntu applications withouth the need to install any additional drivers. You will be able to autoconnect to the modem in network manager settings:

Network Manager Menu

Edit your eth0 settings by ticking Connect automatically in order to connect everytime you turn on your PC:

enter image description here

In case you need to stick to USB connection then the option to autoconnect may depend your USB driver's capabilities.

share|improve this answer
    
I did That but it declines to run automatically when I log to my PC . Is there any other solution even commands in Terminal . –  user12819 Mar 23 '11 at 10:01
    
sorry to hear that. Are other network connections installed? Is you modem powered on before you login? –  Takkat Mar 23 '11 at 10:17
    
there is other connection but for LAN and Idon't use it The modem run when I turn on the PC but when I log to ubuntu it doesn't run. –  user12819 Mar 23 '11 at 20:41
    
Is there any other answer? –  user12819 Mar 25 '11 at 14:30
    
was not the title clear ? –  user12819 Mar 25 '11 at 19:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.