Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i got a new ACER predator AG3620-UR308 which came with windows 8, so i wanted to run ubuntu 12.04.2 on it as a dual booting. To be honest, i've been doing dual booting for a while now so, i did the right thing. the box came with 2TB HDD. so i made 4 partitions with a raw partition just after the windows installation partition

I always do manual installation so even if ubuntu didn't detect windows 8, it was ok for me. So i created swap area and finished the installation etc....Grub was install on the only drive there which is sda.

After reboot, grub doesn't even come up.So it always boot in windows 8. I did repeat the installation process twice and yield same result. which is weird because this method always works for me so far.Even the laptop am using to write this post is a dual booting windows 7/ mint nadia installed the same way. Is there anything new in windows 8 that i didn't make provision for? Before starting the installation, all i read about was that , windows 8 should be installed first and ubuntu after. I went ahead and disable secure boot from the BIOS and enabled CSM (don't even know what it means) according to Acer custhelp site . I boot from USB and did fdisk -l bellow is the result:

ubuntu@ubuntu:~$ sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't  support GPT. Use GNU Parted.


Disk /dev/sda: 2000.4 GB, 2000398934016 bytes 
255 heads, 63 sectors/track, 243201 cylinders, total 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x8c361cb5

Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  3907029167  1953514583+  ee  GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/sdb: 8178 MB, 8178892800 bytes
255 heads, 63 sectors/track, 994 cylinders, total 15974400 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0006a87e

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048    15972351     7985152    b  W95 FAT32
ubuntu@ubuntu:~$

Can anybody shed some light? thank you in advance

EDIT Hey, i just did another trial with 13.04 this time and still no luck.

bios: secure-boot: disabled   
enable CSM : always 

  1-delete previous ubuntu partition and swap area partition.now having free space    
  2- used usb installer to prepare usb with ubuntu-13.04-desktop-amd64.iso   
  3- rebooted : liveusb didnt detect windows 8, used something else   
  4-created partition ext4 for /   
  5-created partition for swap-area   
  6- default grub path is /dev/sda and clicked install

Acer always boots into windows.

NEW EDIT

Hello after following the boot-repair suggestion installed on the liveUSB, i could now see grub but can't log into windows anymore as it's not in the list. The boot-repair also completed with an error, i guess logged on pastin.ubuntu bellow is the screen shot of how my drive is organized gparted shot

share|improve this question
    
Windows 8 pre installed? Turned off secure boot? This can help - askubuntu.com/questions/221835/… –  Web-E Jul 1 '13 at 10:21
    
Hello, i've read it. I did disable secure boot before the second installation. From within windows linux partition has already be created.Besides i use ubuntu 12.04.2 that should actually work. But for some reason it doesn't work for me :( –  black sensei Jul 1 '13 at 10:52

2 Answers 2

up vote 2 down vote accepted

Try using Boot Repair in Ubuntu.


Installing Boot Repair

  1. Open the Terminal, then type:

    sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

  2. Press Enter.

  3. Then type:

    sudo apt-get install -y boot-repair && (boot-repair &)

  4. Press Enter

Using Boot Repair

Search for Boot Repair in the dash and launch it. Then click the "Recommended Repair" button and wait until it's finished.


Reboot. It should work now, although your GRUB is probably littered with useless entries.

share|improve this answer
    
where exactly this is done? i can't boot in ubuntu so i assume this is done with liveUSB or liveCD.Are we on the same page? –  black sensei Jul 2 '13 at 17:29
    
Hi, I've updated my post with NEW EDIT. kindly see into it , thanks –  black sensei Jul 2 '13 at 20:10
    
What was the error that boot repair gave? –  Jop Vernooij Jul 2 '13 at 22:01
    
sorry i thought i pasted it paste.ubuntu.com/5838337 –  black sensei Jul 3 '13 at 7:45
    
@blacksensei Sorry I didn't see it. Hm... –  Jop Vernooij Jul 3 '13 at 8:00

You have to write GRUB manually. Boot from CD and run this command:

sudo grub-install /dev/sda

In some cases you have to run more commands. Let's assume that you have Windows partition on /dev/sda1, swap on /dev/sda5, /boot on /dev/sda6 and Ubuntu root on /dev/sda7. Then you have to run these commands:

sudo su
mount /dev/sda7 /mnt
cd /mnt
mount /dev/sda6 boot
mount --bind /dev dev
mount --bind /proc proc
mount --bind /sys sys
chroot /mnt
grub-install /dev/sda
update-grub2

This will make the job what standart installer fails for some reason. The advantage of this method is that you don't have to install any third-party packages.

share|improve this answer
    
I am having this error: Path /boot/grub is not readable by Grub on boot. Installation ins impossible. Aborting –  black sensei Jul 1 '13 at 13:40
    
@black, is your boot settings branch located on another partition than Ubuntu? Then you have to do some preparations. I'll edit my answer to make it more helpful in thes situation. –  Danatela Jul 2 '13 at 1:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.