Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am trying to connect my machine to my work's entirely windows network and I am having a few issues:

  • Whenever I try to access the server, the authentication dialog just keeps popping back up.
  • I cannot connect to the printers (it says connecting to device failed)

I have tried setting up samba, winbind, kerberos, likewise open all to no avail. I have a feeling I am just setting them up wrong.

My nautilus shows this when I go to Network > Windows Network > MASTERMAGNETS

enter image description here

I can ping both MASTERMAGNETS.LOCAL and after modifying my /etc/hosts

james@jamesmaddison:~$ cat /etc/hosts localhost jamesmaddison MASTERMAGNETS.LOCAL Sharp-Printer

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

I believe that's the correct domain (not sure if that's the correct term) as when I do nslookup MASTERMAGNETS.LOCAL I get the following:

james@jamesmaddison:~$ nslookup MASTERMAGNETS.LOCAL


It all worked fine before I reinstalled Ubuntu and now I just cannot get access to the server.

All help is appreciated, I need to get this working or I fear I will be forced to develop in a windows environment :(

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I had the network admin delete my account and remake it and that seemed to work now.

I don't know whether Kerberos automatically synced or anything after that but it worked!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.