Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am very close to the solution, just need to know how to get usb-storage to load

I have tried most of the advice on askubuntu and other sites, usb_storage enable to fdisk -l. But I am unable to find steps to get it working again.

sudo lsusb results

Bus.... skipped 4 lines
Bus 004 Device 002: ID 413c:3012 Dell Computer Corp. Optical Wheel Mouse 
Bus 005 Device 002: ID 413c:2105 Dell Computer Corp. Model L100 Keyboard 
Bus 001 Device 005: ID 8564:1000

sudo dmseg | tail reports

[   69.567948] usb 1-4: USB disconnect, device number 4
[   74.084041] usb 1-6: new high-speed USB device number 5 using ehci_hcd
[   74.240484] Initializing USB Mass Storage driver...
[   74.256033] scsi5 : usb-storage 1-6:1.0
[   74.256145] usbcore: registered new interface driver usb-storage
[   74.256147] USB Mass Storage support registered.
[   74.257290] usbcore: deregistering interface driver usb-storage

fdisk -l reports

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   972656639   486327296   83  Linux
/dev/sda2       972658686   976771071     2056193    5  Extended
/dev/sda5       972658688   976771071     2056192   82  Linux swap / Solaris

I think I need steps to install and get usb_storage module working.

Edit : I tried sudo modprobe -v usb-storage reports

sudo modprobe -v usb-storage
insmod /lib/modules/3.2.0-48-generic-pae/kernel/drivers/usb/storage/usb-storage.ko 

Edit :

jsiddharth@siddharth-desktop:~$ sudo udevadm monitor --udev
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing

UDEV  [4757.144372] add      /module/usb_storage (module)
UDEV  [4757.146558] remove   /module/usb_storage (module)
UDEV  [4757.148707] add      /devices/pci0000:00/0000:00:1d.7/usb1/1-6 (usb)
UDEV  [4757.149699] add      /bus/usb/drivers/usb-storage (drivers)
UDEV  [4757.151214] remove   /bus/usb/drivers/usb-storage (drivers)
UDEV  [4757.156873] add      /devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6:1.0 (usb)
UDEV  [4757.160903] add      /devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6:1.0/host9 (scsi)
UDEV  [4757.164672] add      /devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6:1.0/host9/scsi_host/host9 (scsi_host)
UDEV  [4757.165163] remove   /devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6:1.0/host9/scsi_host/host9 (scsi_host)
UDEV  [4757.165440] remove   /devices/pci0000:00/0000:00:1d.7/usb1/1-6/1-6:1.0/host9 (scsi)

Narrowing down more : Seems like I need usb_storage to load as a module

jsiddharth@siddharth-desktop:~$ lsmod | grep usb
usbserial              37201  0 
usbhid                 41937  0 
hid                    77428  1 usbhid

Still no usb driver mounted. Nor does a device show up in /dev. Any step by step process to debug and fix this will be really helpful.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.