Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I built and installed my own version of package tora with Oracle InstantClient support using this guide. It has the same version as the package available from standart Ubuntu repository so Synaptic tells me it needs to be updated. I blocked it there, however, apt-get does not know about it and installs the default useless version everytime I do apt-get upgrade. How can I disable such behavior? I guess I should correct the build number of my package but I don't know where to hack sources. My tora version is 2.1.3-2build1.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You need to set the hold flag so that dpkg knows to ignore it. This program should do it http://manpages.ubuntu.com/manpages/hardy/man1/dpkg-hold.1.html " dpkg-hold tora" or the package name if different. Restart then check synaptic is ignoring it before updating though!

share|improve this answer
    
Thanks! I installed it using apt-get install dlocate. It seems working, but I'd also like to set my own version of tora package. Can you kindly explain me how to do that? –  Danatela Jul 1 '13 at 7:12
    
I don't have much experience but it looks like you change the number in the change log and put it back into a package. wiki.debian.org/PackagingTutorial#debian.2Fcontrol –  namingFailed Jul 1 '13 at 7:28
    
OK. Thanks for giving the clue. –  Danatela Jul 1 '13 at 7:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.