Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 12.04LTS installed on a dual-booted machine i5 dual core 8G RAM and it's been working fine, but today for some reason when I logged out and tried to log back in it is stuck at the login page, i.e. the mouse and the keyboard are not responding. The mouse is stuck at the top left corner of my screen, and I can do nothing but to turn the machine off. (I have been using logitech wireless mouse and keyboard.) I can not access the virtual console using Alt F1 or Ctrl Alt F1 either!

Here is what I have tried so far:

  1. Verified it is not a H/W problem since the mouse and keyboard work fine with windows7
  2. Booted with ubuntu installation dvd and ran trial mode and mouse and keyboard worked fine.
  3. Tried bypassing the login screen by booting into recovery mode and editing tty1.conf, but to no avail.
  4. I moved .Xauthority .profile and .bashrc from my $HOME to another location so my login would proceed completely by system defaults. But this did not help
  5. From recovery mode commandline used to dpkg-reconfigure to switch between gdm and lightgdm. This did not help either.
  6. By the way, when in recovery mode as root from command line I mount the filesystem, all apps work fine. Python is Ok, octave is ok, vi is ok etc.

I have a feeling if I could only bypass the login screen, and automatically get into the desktop, I will be ok. But I haven't been able to accomplish this either.

I desperately need help please. Thank you in advance.

Update: So I tried to switch to lightdm by dpkg-configure lightdm. This at least brings me up to the classical linux commandline login prompt but without a gui. Should I install startx? Should I install ubuntu-desktop?

share|improve this question
This happened to me once I remove my xorg-server. You can try to reinstall xorg-server to see if you can solve the problem... – Terminal User Oct 12 '13 at 10:58
sudo service lightdm restart , does this work ? – Serg Feb 18 '15 at 18:09

Phew! Thanks for the help blue; so this is what I ended up doing:

  1. From grub boot menu entered recovery
  2. mount -o rw,remount /
  3. Commented out any samba or nfs mounts in my fstab file, as these were interfering with enabling networking.
  4. Enabled networking
  5. sudo apt-get update and sudo apt-get upgrade and sudo apt-get update --fix-missing
  6. dpkg-reconfigure lightdm (I switched to lightdm)
  7. Rebooted, this gave a properly functioning command line login shell. 8.sudo apt-get install ubuntu-desktop
  8. startx

Things seem to be working, but the desktop did crash once for no apparent reason. If the desktop crashes again, I might remove ubuntu-desktop and just use an old 90's style cruddy twm or something.

share|improve this answer
If this was the working solution, please mark it as accepted. – O. R. Mapper Mar 8 '14 at 7:29
Can you clarify how to get into that recovery mode, please? My Ubuntu is stuck in the same situation, and when I try to boot using the recovery item from Grub, I still get to a login screen where I cannot do anything. – O. R. Mapper Apr 25 '14 at 21:33
I have created a separate question for that particular issue. – O. R. Mapper May 3 '14 at 9:00

Try run sudo dpkg --configure -a in the terminal. It will enable the mandatory things.

share|improve this answer
I tried it, again no effect. – user169954 Jul 1 '13 at 5:55
Try sudo apt-get upgrade and sudo apt-get update --fix-missing – blue Jul 1 '13 at 8:04
I tried this, but still the same thing. – user169954 Jul 1 '13 at 14:48

Check your Ubuntu Partition and consider to deduct the bad sectors. Here is my experience to the same problem, when I installed custom partition ubuntu. I overlooked the Hard Disk Bad Sectors When I do Custom Partition. So the swap cannot mount properly. So I found out size of my hard disk Badsectors. Then I minus them from my total hard disk space and minus again with some extra space and then made the custom partition. Now the problem solved and Ubuntu began to load excellently.

share|improve this answer

As suggested here [1], this solved my keyboard problem when trying to login at LightDM screen (mouse worked fine):

sudo dpkg-reconfigure keyboard-configuration


share|improve this answer

I don't think it's an X11 problem. Switch to a virtual console using Alt F2 and login as your normal user. Now delete the .config .gconf and .compiz-1 folders from your home directory.

rm -rf .config .gconf .compiz-1

This has fixed a couple of my problems in the past. The only downside is you'll have to redo all your settings again (wallpapers, nautilus bookmarks etc...)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.