Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There is RAID0 of 2 drives connected through Silicon Image 3132 SATA SoftRAID controller. Under Windows it was partitioned as one dynamic GPT-disk having 4 TB NTFS volume. There is a lot of music and movies on the drive. I'm trying to get him to be seen under Ubuntu as a single disk, not as 2 by 2 terabytes.

I tried to read it through dmraid, had no success, it is not displayed in /dev/mapper. Also tried to configure the kernel, but did not find anything suspicious, the driver for my controller was turned on. There is also a driver from the manufacturer, but it is only available for RHEL and SLES. Here it's reported that SoftRAID is supported by the kernel, but apparently not completely. If I thrust drives in the AMD controller, built into the motherboard, the drive is seen as a single, but the data is lost. I know about mdadm that it is able to ditch all the information on the disks. So, is it possible to somehow create an array without actually recording information on used drives and to make the system correctly identify sections on it later?

Information about the array:

/dev/sdf - Disk 0
/dev/sdg - Disk 1
Array type: Stripe
Chunk Size: 64KB

Also, a device /dev/md1 is created using command mknod /dev/md1 b 9 1

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Had to destroy my data, but found a solution. The --build command actually constructs an existing array and runs it. The full command in my case looks such:

sudo mdadm --build --verbose --chunk=64K /dev/md1 --level=0 --raid-devices=2 /dev/sdh /dev/sdi

I think that chunk and level options are not necessary, but use them to be sure everything goes right. And I also should never use the --create command, because it destroys existing arrays.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.