Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I’ve been trying to install Ubuntu 13.04 64-bit edition on an ASUS (K53Z) laptop. I have Windows 8 64-bit installed in a non UEFI mode (I think since it starts-up with the Windows logo and I don’t have the UEFI settings). This laptop had installed Windows 7 and when I upgraded it I didn’t knew about the UEFI advantages. I tried several times to install Ubuntu from a USB device and it loads the logo and then I can’t go further in the installation. I thought it was the version of Ubuntu and tried to install Fedora (even if I personally prefer Ubuntu). I had the same problem: Fedora’s logo appears and it gets stuck. I tried also to boot from different USB devices and didn’t work either. My Bios has EFI options to boot but they were not enabled. So I tried to enable them to boot the USB in UEFI mode. A menu shows up with the options of install Ubuntu and try Ubuntu. If I click the Install or try option, I get a black screen and I can’t go further with the install (which I think is normal since I don’t have Windows 8 in EFI mode).

My hypothesis is that the Bios isn’t letting Ubuntu write or read from my SSD, because the activity LED in the USB memory is on when it’s loading the installation files. Once the files are ready and the Ubuntu logo is loaded I don’t see a LED activity on neither the SSD or the USB.

Thanks If I missed data you can ask me.

share|improve this question

You would never suspect the ambitious Secure Boot, won't you? Go to BIOS settings and turn it off. Windows 8 has this new feature that secures up the system, and it's working. Secure Boot found that your Ubuntu has a different signature than the Windows 8 one. So try to uncheck the Secure Boot.

share|improve this answer
I would be extremely surprised if a computer that came with Windows 7 used Secure Boot, since Windows 7 doesn't support it. Ubuntu 12.10 was the first operating system to support it, closely followed by Windows 8 and then Ubuntu 12.04.2. – Jo-Erlend Schinstad Nov 9 '13 at 17:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.