Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a bash script that I need to execute. It seems that I can't run in in my terminal because it has a slightly different syntax.

I could run the first file like bash ./configure but it produces a makefile that I can not use. If I try bash make it tells me that it can't execute make.

How do I run this make file in bash?

I tried cd /usr/bin ./bash but it tells me that it can't find bash.

So how do I start bash?

share|improve this question
    
If you're trying to build a software from source, you should enter ./configure (without bash in front) followed by make. Do you have make installed? it's probably in the build-essential package. –  gniourf_gniourf Jun 30 '13 at 22:03
add comment

1 Answer

up vote 1 down vote accepted

try using the command "bash" this will open an interactive bash terminal and then use it like the normal terminal and when you are done use the command "exit" to go back to your regular terminal.

share|improve this answer
    
nothing opens if I type "bash" :( –  Maik Klein Jun 30 '13 at 20:47
    
it won't look like its opened anything. try typing "ps -p $$" this should say that you are now using bash –  namingFailed Jun 30 '13 at 20:51
    
no it still tries to use sh, if I use bash and then use make I get this "/bin/sh: 1: Syntax error: "(" unexpected" –  Maik Klein Jun 30 '13 at 21:00
    
This may be the problem, wiki.ubuntu.com/DashAsBinSh there is some troubleshooting. i.e change the SHELL variable in the make file to /bin/bash –  namingFailed Jun 30 '13 at 21:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.