Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have ubuntu-12.04 on my virtualbox and I have two kernels in /boot (old and new). When I restart the vbox no grub appears to choose! and the result of cat /proc/cmdline still shows the old kernel is running.

I tried pressing shift but it also does not work!

share|improve this question
    
Alternatively, comment GRUB_HIDDEN_TIMEOUT, per askubuntu.com/a/16049 – ignis Jul 1 '13 at 10:52
    
Thanks @ignis for the link. – beginner Jul 2 '13 at 1:09
up vote 15 down vote accepted

You have to know that VirtualBox is just Virtual, so many things can be different.

Reboot your virtual machine and when you see Oracle's logo , click the screen (focus there) and then hold down Shift until Grub menu appears.

share|improve this answer
    
Wow thank you so much it took so much of my time and now it works:) – beginner Jun 30 '13 at 20:14

Edit /etc/default/grub:

gksudo gedit /etc/default/grub

And add a # in front of GRUB_HIDDEN_TIMEOUT=0

Finally, apply with:

sudo update-grub

Credits: http://askubuntu.com/a/16049/263353

Note: If you plan to change GRUB2 shell keyboard layout, forget immediately about using the Shift method. It may be normal that terminal_input at_keyboard make this key not work anymore.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.