Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04. As you might know Google Earth 7 doesn't work in Ubuntu 12.04 yet.

I installed Google Earth via make-googleearth-package --force command. My installation was successful. At the beginning everything was working fine. But after some days I had a problem. When I type in "Fly to" box a city I wanted to search for it. It gives me "invalid HTTP request" error as seen in the picture:

Google-Earth picture

How to solve?

P.S: I removed and reinstalled it but problem still persists. I can search globe via mouse only.

share|improve this question

2 Answers 2

up vote 13 down vote accepted

This is due to an old libcurl version, that seems to cause the trouble. If you already have libcurl on your system (and I am pretty sure Ubuntu 12.04 has), you can simply rename the libcurl coming with Google Earth like this:

sudo mv /usr/lib/googleearth/libcurl.so.4 /usr/lib/googleearth/backup_libcurl.so.4

And the problem should be gone (the path in my Linux Mint and probably other distributions is /opt/google/earth/free/libcurl.so.4).

share|improve this answer
1  
This also solved the same issue on Fedora 18 withgoogleearth 6.0.3 (except the earth version of libcurl was in a slightly different place - /usr/lib/googleearth/libcurl.so.4) THanks –  user177629 Jul 23 '13 at 11:41
    
Doesn't work. stiil waiting an answer. Thank you. @bytefish –  Hejar Mukriyani Jul 29 '13 at 19:32
    
That surprises me. Which curl version is Ubuntu 12.04 shipped with? –  bytefish Jul 29 '13 at 19:37
1  
that worked for me on LMDE UP6 –  Dr Casper Black Aug 9 '13 at 20:18
    
Thanks Andy Paterson. I tried the same solution as you mentioned for Fedora ( /usr/lib/googleearth/libcurl.so.4 ) it worked like a charm for my Ubuntu 12.04 distro. @AndyPaterson –  Hejar Mukriyani Sep 21 '13 at 20:23

I suddenly started seeing this error after running several updates. I tried a number of things unsuccessfully and finally updated GE to 7.1 - it couldn't hurt. Problem went bye bye! I hope this works for you.

share|improve this answer
    
This worked for me too. Reminds me that sometimes manually installed programs need to be updated. –  James Mar 2 at 3:23

protected by Community Jul 23 '13 at 12:17

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.