Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm having problems connecting my WIFI in Ubuntu 13.04 .

So I was wondering if filling in the data manually ie: the IPv4, IPv6, the SSID and BSSID info etc. I did try this before but maybe I put in the wrong data or maybe not enough.

Would that make it work?

I just don't know how to find out some of the data you need to put in?

I'm new and it's confusing. Does anyone know the solution?

Here is lspci:

james@james-MM061:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
03:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
03:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 0a)
03:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 05)
0b:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

Computer information:

  • Model: Dell MM061
  • Mobile Intel(R) 945GM Express Chipset Family [Display adapter] (2x)
share|improve this question

marked as duplicate by Radu Rădeanu, Eric Carvalho, Seth, Eliah Kagan, user68186 Jul 2 '13 at 15:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
It shouldn't be necessary to supply all the above stuff. Can you explain what the problems are, and also provide some relevant hardware info. –  mikewhatever Jun 29 '13 at 21:33
    
i didnt think so. well, when ubuntu is up and running, there seems to be no internet connection whatsoever, it doesn't display any possible connections at all. ive tried re-installing and typing in the info myself but nothing works, i tried looking in the network folder and then in windows network but it says theres no such file there, what kind of hardware info do you need? –  James Jun 29 '13 at 22:25
    
Edit your question to include the output of lspci | grep -i network. Also, you should tell us your computer model (ideally the wireless card model too). Please edit your question to include this info (try not adding it in a comment). –  edwin Jun 30 '13 at 0:01
    
ive updated that lspci @edwin but dont really know what im doing there??? –  James Jun 30 '13 at 1:34
1  
Open a terminal (Ctrl+Alt+T), copy the commands I've written in my previous comment (verbatim), and paste them in the terminal, then press Enter. The output of lspci | grep -i network should be shorter. (The output you've provided is difficult to interpret.) –  edwin Jun 30 '13 at 2:42

1 Answer 1

I assume you have a wired connection available (Ethernet). So plug your Ethernet cable to your computer and try the following:

1- Boot into Ubuntu

2- Open a terminal by pressing Ctrl+Alt+T

3- Type in the following (verbatim!)

sudo  apt-get  update  &&  sudo  apt-get  upgrade

press Enter, the command will prompt for your password (the one you use to login into Ubuntu), type it and press Enter. Wait for it to finish updating your system. Now type:

sudo  apt-get  remove  bcmwl-kernel-source
sudo  apt-get  install  firmware-b43-installer

Wait for the command to finish installing the driver, when done restart your computer. See if it worked by login into Ubuntu (unplugging the Ethernet cable) and seeing the if you have wireless Internet now.

share|improve this answer
    
the problem there is that even the ethernet cable wont work, ive tried using the ethernet cable but it doesnt find it, it just seems impossible to get any kind of connection in ubuntu, its like its missing the drivers for it –  James Jun 30 '13 at 3:17
    
That really shouldn't be the case... Ubuntu brings the Ethernet drivers by default. Are you sure about this? Try connecting the cable now and following the instructions (if you encounter problems please try uploading a screenshot). –  edwin Jun 30 '13 at 3:19
    
yes im certain of it, i put the ethernet cable in when running windows and have no problem with it, if i run ubuntu with the ethernet cable in, its as if theres nothing there, it just does nothing at all and wont get any connection, i will try again but i doubt anything will be any different as ive tried this a couple of times. i will try run through all the methods ive seen and if nothing works i will try get some screenshots to upload, this could take an hour or so due to me switching back and forth OS as i have to save the screenshots on SD card to transfer them between OS –  James Jun 30 '13 at 3:27
    
ok i have a screenshot of the problem @edwin but how do i post it to you? it basicall says after the first command "W: failed to fetch gb.archive.ubuntu.com/ubuntu/dists/raring-backports/multiverse/… Something wicked happened resolving 'gb.archive.ubuntu.com:http' (-11 - System error) –  James Jun 30 '13 at 4:16
    
i also tried opening the synaptic package manager which apparently was not installed, it gave me the command to install it, after entering it it said it was not available that it is referred to ny another package and that it may mean the package is missing, has been obsoleted, or is only available from another source E: package 'synaptic' has no installation candidate. have i done something monumentally wrong for this to happen? it seems no one else has had a major problem like this, everyone seems to get around their problem but mine are stacking up the deeper i delve –  James Jun 30 '13 at 4:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.