Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am just recently installed Linux on my Oplitex Gx280. Every time T log on I am met by the Grub 1.99 screen and select (Ubuntu, with Linux 3.5.0-34-generic).

I need my computer to boot up automatically so I adjusted the /etc/default/grub file and set GRUB_TIMEOUT=3 and ran update-grub. However the Grub menu didn't change and have discovered there is no time out and won't advance until you choose an option.

I have even tried using the GRUB_SAVEDEFAULT=true line. I have also done a reinstall of grub from my boot cd with no luck. This is what my grub file looks like after the reinstall:

If you change this file, run 'update-grub' afterwards to update # /boot/grub/grub.cfg. # For full documentation of the options in this file, see: # info -f grub -n 'Simple configuration'

GRUB_DEFAULT="Ubuntu, with Linux 3.5.0-34-generic"
GRUB_HIDDEN_TIMEOUT="5"
GRUB_HIDDEN_TIMEOUT_QUIET="false"
GRUB_TIMEOUT="3"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs # This works with Linux (no patch required) and with any kernel that obtains # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...) 

#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef" 
# Uncomment to disable graphical terminal (grub-pc only) 
#GRUB_TERMINAL="console" # The resolution used on graphical terminal # note that you can use only modes which your graphic card supports via VBE 
# you can see them in real GRUB with the command `vbeinfo' #GRUB_GFXMODE="640x480" 
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux #GRUB_DISABLE_LINUX_UUID="true" 
# Uncomment to disable generation of recovery mode menu entries #GRUB_DISABLE_RECOVERY="true" 
# Uncomment to get a beep at grub start #GRUB_INIT_TUNE="480 440 1"

GRUB_DISABLE_OS_PROBER="true"
GRUB_SAVEDEFAULT="true"

Please help me solve this issue and keep in mind that I am fairly new to Linux Thx

share|improve this question
    
Originally posted as an answer by firekage - "Have you tried with this: GRUB_TIMEOUT="0"" –  gertvdijk Jun 29 '13 at 17:42
add comment

2 Answers 2

up vote 0 down vote accepted

I have answered my question. Apparently Ubuntu didn't shutdown properly at some point. In this situation Grub defaults to the selection page and forces you to choose. The bug is reaching this screen in this situation also is considered improper and the vicious cycle begins causing you to always reach the Grub boot screen and always having to manually make a choice.

To fix this you must edit /etc/grub.d/00_header and edit the record fail section to

if\${recordfail} = 1 ]; then
  set timeout=${GRUB_TIMEOUT}
else
  set timeout=${GRUB_TIMEOUT}
fi
EOF

This means if there is any failure it it will continue after the time you have specified in /etc/default/grub under GRUB_TIMEOUT. Then run sudo update-grub

Before you edit this it probably says something along the lines of RECORD_FAIL(I don't remember what it exactly said and have since edited mine) with a -1. That -1 time value was what was forcing me to manually make a choice. You might be able to just edit the -1 to some time value, but changing it to what is showed above will defiantly fix the problem.

share|improve this answer
    
You can accept your answer by clicking the checkmark to the left. This will mark the question as solved. –  minerz029 Jan 12 at 22:13
add comment

Have you tried with this:

GRUB_TIMEOUT="0"

I tried it just now, it works. I have also 0 in "hidden grub timeout"

Here is my grub:

firekage@deusex:~$ cat /etc/default/grub 
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
share|improve this answer
    
This is really a comment, not an answer. With a bit more rep, you will be able to post comments. For the moment I've added the comment for you, and I'm flagging this post for deletion. –  gertvdijk Jun 29 '13 at 17:41
    
Yes I have tried setting GRUB_TIMEOUT="0", it appears as any change I make to the Grub file makes no change to the boot screen –  Ethan Jun 30 '13 at 2:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.