Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

David Planella wrote in his answer to a question I posted that:

...the recommended way to develop apps for Ubuntu is the Ubuntu SDK.

So I installed it, but looks like the supported programming language is C++. Does it mean I will need to know C++ to develop a new application for Ubuntu? Is C++ the recommended programming language for Ubuntu application now?

What about Python, I started learning it hoping to develop applications for Ubuntu.

share|improve this question
    
developer.ubuntu.com/resources/programming-languages/… - In the menu there are only C++, Javascript and QML listed. –  Czarek Tomczak Jun 29 '13 at 16:25
1  
@CzarekTomczak I know that, but I think 2 day ago they change the site and before that you could see that the recommended way to develop applications for Ubuntu was with Python and Quickly. Check out this question I asked yesterday link –  Zignd Jun 29 '13 at 18:09
    
Where did you read that the supported language is C++? You can certainly use C++, but the language we recommend to start writing apps that run both on the desktop and on mobile devices is QML - check out the getting started page, which includes all info you need and a tutorial to write your first Ubuntu SDK app. –  David Planella Jun 30 '13 at 11:38
1  
@DavidPlanella but according to the Wikipedia article about QML it's: QML (Qt Meta Language or Qt Modeling Language[2]) is a JavaScript-based, declarative language for designing user interface–centric applications., so it's not a programming language, right? –  Zignd Jul 21 '13 at 0:32

3 Answers 3

up vote 14 down vote accepted

It is currently not possible to use Python with the Ubuntu SDK. The Ubuntu project is tightly focused on getting a stable mobile phone OS by October 2013, and a full convergent story by Ubuntu 14.04. In order to achieve this, QML has been the language of choice to recommend to app developers to write their software.

Technically, provided that there are Qt/QML bindings in Python available, it should be possible to use it with the SDK. However, given the time frames, we want to focus on supporting one toolkit and doing it well, rather than supporting multiple options.

If any community members are interested in contributing towards it, it should not be an impossible task, but right now the status of Python Qt bindings is a bit complicated: PySide, which would be the natural choice, will not be ported to Qt5 in the foreseeable future. PyQt has just been ported to Qt5, but it might not be the best choice in terms of licensing commercial applications, which will coexist with free, open source apps in the ecosystem. See more context on this earlier question.

share|improve this answer

Now you can, got to new project - Python (at the bottom of the list in the sidebar) - and select class or source.

share|improve this answer

Python and Ubuntu are inseperable, any device running Ubuntu will definitely have python running now and in the future, whether this is desktop or mobile. They seem to be promoting Javascript/QML now, but it doesn't mean python is deprecated, see Ubuntu APIs:

http://developer.ubuntu.com/resources/platform/api/12-04/.

See also:

share|improve this answer
1  
That's correct. However, for writing convergent applications we're recommending the Ubuntu SDK, which, unless someone interested in working in them steps up, has no Python bindings. –  David Planella Jun 30 '13 at 12:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.