Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Xubuntu 12.04.2. My soundcard is detected:

thomas@thomas-pc:~$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
Home directory /home/thomas not ours.
card 0: Intel [HDA Intel], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Everything is put to max in alsamixer and nothing is muted (all the sliders are on OO. My speakers do not work, but when I plug in a headphone I hear it very soft. When I connect my stereo and put the sound VERY loud (3-blocks-of-complaining-neighbours loud) I hear it on a normal level but crackling.

I added

options snd-hda-intel model=mbp5
amixer set IEC958 off

to at the end of /etc/modprobe.d/alsa-base.conf.

When it's still not working I tried everything here: https://help.ubuntu.com/community/SoundTroubleshooting

1

>>> list-sinks
1 sink(s) available.
  * index: 0
    name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9959
    volume: 0: 100% 1: 100%
            0: 0.00 dB 1: 0.00 dB
            balance 0.00
    base volume: 100%
                 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 371.52 ms
    card: 0 <alsa_card.pci-0000_00_1b.0>
    module: 4
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "ALC889A Analog"
        alsa.id = "ALC889A Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "0"
        alsa.card_name = "HDA Intel"
        alsa.long_card_name = "HDA Intel at 0x9b500000 irq 46"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.name = "82801H (ICH8 Family) HD Audio Controller"
        device.form_factor = "internal"
        device.string = "front:0"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        alsa.mixer_name = "Realtek ALC889A"
        alsa.components = "HDA:10ec0885,106b3a00,00100103"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-speaker: Speakers (priority 10000, available: unknown)
            properties:

        analog-output-headphones: Headphones (priority 9000, available: no)
            properties:

    active port: <analog-output-speaker>

2 and 3: Doesn't seem an permission issue, the sound is very far away (See opening paragraph).

4

thomas@thomas-pc:~$ sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
Home directory /home/thomas not ours.
card 0: Intel [HDA Intel], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

5

thomas@thomas-pc:~$ find /lib/modules/`uname -r` | grep snd
/lib/modules/3.2.0-48-generic/kernel/sound/core/snd-hwdep.ko
/lib/modules/3.2.0-48-generic/kernel/sound/core/snd-pcm.ko
[.. huge lists continues ..]
/lib/modules/3.2.0-48-generic/kernel/sound/pcmcia/pdaudiocf/snd-pdaudiocf.ko
/lib/modules/3.2.0-48-generic/kernel/sound/pcmcia/vx/snd-vxpocket.ko
thomas@thomas-pc:~$ 

6

thomas@thomas-pc:~$ lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
    Subsystem: Apple Inc. Device 00a4
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at 9b500000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd-hda-intel

7 I guess it's supported. Linux mint and Xubuntu 13.04 had no trouble with sounds. Everything worked out of the box

Thanks in advance

Edit: alsa-info.sh output:

WARNING: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'amixer'
ALSA Information Script v 0.4.62
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

  dmesg
  lspci
  lsmod
  aplay
  amixer
  alsactl
  /proc/asound/
  /sys/class/sound/
  ~/.asoundrc (etc.)

See './alsa-info.sh --help' for command line options.

WARNING: /etc/modprobe.d/alsa-base.conf line 45: ignoring bad line starting with 'amixer'
Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ...  Done!

Your ALSA information is located at http://www.alsa-project.org/db/?f=6cffc584284d4c0b266eb53249824ef83d6c4e3e

Please inform the person helping you.

thomas@thomas-pc:~$ 
share|improve this question
add comment

1 Answer

Update Ubuntu. That may fix the issue. If you still have the issue, run:

killall pulseaudio; rm -r ~/.pulse*

If that did not help, run:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

After that, reboot. If it did not help, post the output of this command:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && chmod +x ./alsa-info.sh && ./alsa-info.sh

Follow the instructions here for a full guide on troubleshooting sound.

share|improve this answer
    
Thanks for your answer. The killall did not work. I ran the longer command you gave me. I have watched the whole procedure, no errors or whatsoever. Rebooted the system, same problem. I should have mentioned that I see my sound bar moving in Sound Settings if I play any sound. –  Thomas Jun 28 '13 at 20:30
    
Sorry for the double post. I have updated my question with the output of alsa-info.sh. It's at the end –  Thomas Jun 28 '13 at 20:33
    
There is a chance your playback device is being muted by default. run sudo apt-get install pavucontrol then pavucontrol. Look at PulseAudio and see if either the input or output device is muted. You can tell by if a mute icon is depressed. Also, try setting the ALSA plug setting from "Built-in Audio Analog Stereo" to another audio device. From the Playback tab, change the System Sounds Volume to 100%. –  Dillmo Jun 28 '13 at 20:52
    
The setting was depressed (physically, not mentally). I went ahead and tried the 12.04.2 Xubuntu Live CD. And guess what? Sound ain't working either.. Then I tried 12.10, no sound either.. So I guess this is kind of a lame answer, but I am installing 13.04 now, because it works out of the box (at least on the Live CD). Thanks for your time, sorry if this is a bummer! –  Thomas Jun 28 '13 at 23:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.