Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Complete story:

When I installed Simon Tatham's Portable Puzzle Collection via Ubuntu software center, I noticed some of the newest puzzles were missing. So I decided to get the source files and compile them myself. I uninstalled the collection and downloaded the appropriate tar.gz file from the creator's website.

When I tried make, I got many error messages and I found out I was missing some libraries. I went on installing lib-gtk-2.0 (I think) and my first compilation ever on linux was a success.

I didn't have any decent shortcuts on the appropriate subfolder on the gnome menu (I'm using UNE), so I used alacarte to attach the correct images to the shortcuts.

The first thing I noticed was that the other user accounts didn't have the shortcuts as well. Also, all games suffered from the same problem. Whenever the user opened the system menu in any game, that menu remained drawn forever on the window.

I didn't like that at all, so I decided to only keep the puzzles that were missing form the original collection and reinstall the rest from Ubuntu software center. I though I would at least have most of the games behaving correctly. Therefore, I used alacarte again to delete the "common" shortcuts. After the installation though, I wasn't getting any of the shortcuts on the gnome menu (other user accounts had them correctly), so I decided to delete alacarte's configuration files found inside ~/.config/? (I'm not in front of an Ubuntu-running computer at the moment, so I can't tell for sure).

Now my user account profile is broken. When I log on, the top (and only) bar is not loading at all. I don't want to mess up the profile further so I decided to stop here and ask for help. How to restore the top gnome bar missing and have my shortcuts working correctly from now on? Deleting and recreating the user account is not an option.

Sorry for the long story (I believe it was necessary to explain the steps I took in order to help others help me). Kudos to the guy who can also tell me why the system menus didn't work correctly when I compiled the games myself.

Update:

I'm also missing the windows title bars and borders around. Also the z-order of the windows cannot be changed (Gnome is not bringing the active window in front). Finally, under "Files & Folders" no shortcuts are not working (I'm getting the message "No application is registered as handling this file").

share|improve this question
1  
No need to apologize, the detail is great. –  moberley Aug 26 '10 at 15:47

4 Answers 4

up vote 6 down vote accepted

When you "remove" a menu entry with alacarte, what it really does is create a user-local file that describes the application according to the FreeDesktop.org "Desktop Entry Specification", and indicates that it should be hidden from the menu. Local "desktop entry" files override system-wide ones. These local files are located in ~/.local/share/applications/. Remove the local *.desktop file, and the system-wide one (as installed by the package) will take over again.

share|improve this answer
    
That did the trick. Everything is back to normal. Thank you. –  Anax Aug 26 '10 at 16:46
    
So ~/.local/share/applications/ stores the desktop entries and ~/.config/menus/ stores the menu structure, correct? –  aperson Aug 26 '10 at 20:57
    
@aperson: ~/config/menus/ stores some stuff that GNOME uses to create the menus from the *.desktop files, but I would have to look up the details myself. –  JanC Aug 26 '10 at 21:45

I assume (perhaps incorrectly) that the UNE uses the same config as normal gnome. To reset your menus to a system-wide standard, run this:

mv ~/.config/menus ~/.config/backupmenus

If you can't log in graphically (to the point where you can get a terminal window up), Control+Alt+F1 will give you a text login from whence you can fire off the command.

I suspect the menu isn't loading because there's something awry with the config - that's usually how these things work. If resetting the menu structure doesn't work, you might want to try moving the whole of .config, .gconf, .gnome and .gnome2 out the way, in that order, to see if any fixes things.

share|improve this answer
    
I was almost sure it's alacarte's fault, that's why I decided to try your solution last. I didn't have too, because, after following Jan's advise everything is back to normal. Thank you though. –  Anax Aug 26 '10 at 16:48

gconftool --recursive-unset /apps/panel && killall gnome-panel (from #ubuntu's ubottu) will reset your panels to the default. If alt+f2 is available you can just run that from there.

share|improve this answer
    
I did try your suggestion and at least I got the top bar back. I'm still missing the windows borders and title bars. Also after log off / log on, the problems are back (no top bar). –  Anax Aug 26 '10 at 16:35

I have read in OMG Ubuntu that the new beta of UbuntuTweak can do it with a single click. I had never tried it (the new function, I did try UbuntuTweak but I didn't like it), it's beta software, etc, etc, all the usual warnings, but you can try it as a last measure.

share|improve this answer
    
Ubuntu Tweak did not help. Thanks for your contribution though. –  Anax Aug 26 '10 at 16:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.