Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing Ubuntu 12.04 a week ago wireless internet had been working fine. It stopped working yesterday, however, and I'm at a loss for what to do even after scouring replies to similar posted problems.

I have tried using Google's public DNS and turning off proxy settings on Firefox. I have used nm-tool and lshw to make sure my wireless device and driver are connected. If anyone can help me resolve this issue I would be extremely grateful!

Outputs:

$ ping -c3 www.google.com
ping: unknown host www.google.com

$ ping -c4 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
From 192.168.1.104 icmp_seq=1 Destination Host Unreachable
...
--- 8.8.8.8 ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3014ms

$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) 
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN 
nameserver 127.0.0.1

$ nm-tool | grep DNS
DNS: 192.168.1.1

$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     2      0        0 wlan0

$ ping -c4 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data
From 192.168.1.104 icmp_seq=1 Destination Host Unavailable
From 192.168.1.104 icmp_seq=2 Destination Host Unavailable

--- 192.168.1.1 ping statistics ---
4 packets transmitted, 0 received, +2 errors, 100% packet loss, time 2998ms
pipe 4

$ ifconfig
eth0      Link encap:Ethernet HWaddr 88:ae:1d:58:9d:0b
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:235 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:16266 (16.2 KB)  TX bytes:16266 (16.2 KB)

wlan0     Link encap:Ethernet  HWaddr 00:23:15:35:ce:2c
          inet addr:192.168.1.104  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::223:15ff:fe35:ce2c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:420 errors:0 dropped:0 overruns:0 frame:0
          TX packets:264 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:109306 (109.3 KB)  TX bytes:27642 (27.6 KB)

wmax0     Link encap:Ethernet  HWaddr 64:64:da:04:52:b5
          UP NOARP  MTU:1400  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:20
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

$ sudo lshw -C network
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eth0
       version: 05
       serial: 88:ae:1d:58:9d:0b
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw
latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:41 ioport:6000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff
*-network
       description: Wireless interface
       product: Centrino Advanced-N + WiMAX 6250
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: wlan0
       version: 57
       serial: 00:23:15:35:ce:2c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.5.0-34-generic firmware=41.28.5.1 build 33926 ip=192.168.1.104 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:43 memory:d4600000-d4601fff
*-network
       description: Ethernet interface
       physical id: 2
       logical name: wmx0
       serial: 64:d4:da:04:52:b5
       capabilities: ethernet physical
       configuration: driver=i2400m_usb firmware=i6050-fw-usb-1.5.sbcf link=no

$ dmesg | grep iwl
[   15.388067] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[   15.388072] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[   15.388180] iwlwifi 0000:06:00.0: pci_resource_len = 0x00002000
[   15.388183] iwlwifi 0000:06:00.0: pci_resource_base = ffffc9000067c000
[   15.388186] iwlwifi 0000:06:00.0: HW Revision ID = 0x57
[   15.388263] iwlwifi 0000:06:00.0: irq 43 for MSI/MSI-X
[   15.391065] iwlwifi 0000:06:00.0: loaded firmware version 41.28.5.1 build 33926
[   15.391352] iwlwifi 0000:06:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   15.391356] iwlwifi 0000:06:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   15.391358] iwlwifi 0000:06:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   15.391360] iwlwifi 0000:06:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[   15.391362] iwlwifi 0000:06:00.0: CONFIG_IWLWIFI_P2P disabled
[   15.391365] iwlwifi 0000:06:00.0: Detected Intel(R) Centrino(R) Advanced-N + WiMAX 6250 AGN, REV=0x84
[   15.391427] iwlwifi 0000:06:00.0: L1 Enabled; Disabling L0S
[   15.399876] iwlwifi 0000:06:00.0: device EEPROM VER=0x552, CALIB=0x6
[   15.399880] iwlwifi 0000:06:00.0: Device SKU: 0x1F0
[   15.399883] iwlwifi 0000:06:00.0: Valid Tx ant: 0x3, Valid Rx ant: 0x3
[   15.399910] iwlwifi 0000:06:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
[   15.510715] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   18.862936] iwlwifi 0000:06:00.0: L1 Enabled; Disabling L0S
[   18.863126] iwlwifi 0000:06:00.0: Radio type=0x1-0x2-0x0
[   19.106527] iwlwifi 0000:06:00.0: L1 Enabled; Disabling L0S
[   19.106721] iwlwifi 0000:06:00.0: Radio type=0x1-0x2-0x0
[ 3754.102289] iwlwifi 0000:06:00.0: RF_KILL bit toggled to disable radio.
[ 3754.102506] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.103049] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.114930] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.114945] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.114957] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.115002] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.115039] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.115049] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.116099] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.128114] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3754.138152] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3756.419608] iwlwifi 0000:06:00.0: RF_KILL bit toggled to enable radio.
[ 3756.421101] iwlwifi 0000:06:00.0: L1 Enabled; Disabling L0S
[ 3756.421286] iwlwifi 0000:06:00.0: Radio type=0x1-0x2-0x0
[ 3762.839399] iwlwifi 0000:06:00.0: RF_KILL bit toggled to disable radio.
[ 3762.840221] iwlwifi 0000:06:00.0: Not sending command - RF KILL
[ 3776.333700] iwlwifi 0000:06:00.0: RF_KILL bit toggled to enable radio.
[ 3776.335758] iwlwifi 0000:06:00.0: L1 Enabled; Disabling L0S
[ 3776.335951] iwlwifi 0000:06:00.0: Radio type=0x1-0x2-0x0
[ 4214.253483] iwlwifi 0000:06:00.0: L1 Enabled; Disabling L0S
[ 4214.253686] iwlwifi 0000:06:00.0: Radio type=0x1-0x2-0x0
[ 4305.514303] iwlwifi 0000:06:00.0: L1 Enabled; Disabling L0S
[ 4305.514509] iwlwifi 0000:06:00.0: Radio type=0x1-0x2-0x0

share|improve this question
    
First things first, is your wireless button(switch) on? Can you see any listed networks. Go to a terminal (ctr+alt+t) and type ping -c 3 www.google.com What do you get? –  kregerjd Jun 28 '13 at 6:12
1  
What is the output of ping -c4 8.8.8.8 ? If it did ping, what's the output of cat /etc/resolv.conf and nm-tool | grep DNS? Also, you mentioned you turned off proxy. Is your network in fact using a proxy? –  Alaa Jun 28 '13 at 6:48
    
Thanks for your response, @Alaa. ping -c4 8.8.8.8 gives: PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. From 192.168.1.104 icmp_seq=1 Destination Host Unreachable ... --- 8.8.8.8 ping statistics --- 4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3014ms pipe 3 cat /etc/resolv.conf gives: # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8) # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN nameserver 127.0.0.1 and nm-tool | grep DNS gives: DNS: 192.168.1.1 –  boogaloo Jun 28 '13 at 7:02
    
Hmm. What's the output of route -n and ping -c4 192.168.1.1. Also, you haven't answered the proxy question. Is your network behind a proxy? Also, instead of posting the output in the comment, you can post the output in your question by editing your question, and then post a comment "Added info to my question" =). Look for "edit" underneath your question. If you can't find it, click here. –  Alaa Jun 28 '13 at 7:09
1  
I'm checking for connectivity and correct settings. I'll give a full explanation when we solve the problem =). However, so far, everything seems correct, but you can't even ping your gateway. What's the output of ifconfig, cat /etc/network/interfaces, and sudo lshw -C network? Did you change any settings using nm-tool? Did you set static IP settings? –  Alaa Jun 28 '13 at 10:16
show 14 more comments

3 Answers 3

I had the same problem with the inbuilt network connections manager saying everything was fine, and ifconfig reporting the correct network addresses and that the connection was up and running, I could ping my laptop from the pc but had no internet access.

In my case it was down to also having a GUI network manager, Wicd, which must have been intercepting the connection, because by enabling the wireless lan via the GUI interface, the internet access came back up.

Hope this helps.

share|improve this answer
add comment

I had a similar problem. The wireless connection on my laptop worked and I could connect to the router and to other computers on the network, but not to the internet.

I solved this problem by resetting the /etc/resolv.conf file using

sudo apt-get remove --purge resolvconf 

and restarting the computer.

share|improve this answer
add comment

This can happen if you never ShutDown your PC. Because the IP adresse that the router gave you might of been given to another device. So when you arrive with your device with an "Already given" IP Adresse this problem will appear.

So before doing the next step you MUST be connected to the router. Not internet only the router. so he can give you a new IP Adresse.

Hit Windows key + R, copy/paste the following into the box, and hit enter. cmd /c "ipconfig /release"

again Hit Windows key + R, copy/paste the following into the box, and hit enter. cmd /c "ipconfig /renew"

Hope this works for you...

share|improve this answer
    
This is a windows solution - we have an Ubuntu problem. –  guntbert Sep 27 '13 at 21:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.