Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

xrandr shows:

stel@stel-desktop:~$ xrandr

Screen 0: minimum 320 x 200, current 1400 x 1050, maximum 1600 x 1600
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
CRT1 connected 1400x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1600x1200      60.0 +
   1400x1050      60.0* 
   1600x900       60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1366x768       59.8  
   1360x768       60.0  
   1280x800       59.8  
   1152x864       60.0  
   1280x768       59.9  
   1280x720       60.0  
   1024x768       60.0  
   1024x600       60.0  
   800x600        60.3  
   800x480        60.0  
   720x480        60.0  
   640x480        59.9  
CRT2 disconnected (normal left inverted right x axis y axis)

Graphics card:

stel@stel-desktop:~$ lspci |grep "VGA"    
05:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Park [Mobility Radeon HD 5430]

I am using Ubuntu with Gnome 13.04 64-bit.

My screen is really blurry right now without the ability to set the native resolution of my display connected (1680x1050). How do I fix this?

share|improve this question
add comment

1 Answer 1

Open dash (top left on the tray) and search your programs for AMD Catalyst Control Centre.
First, run the "AMD Catalyst Control Centre (Administrative)" version and enter your password. Then, open the non-administrative version.
From there, go to the display manager tab (on the left) and you should be able to set the display to any resolution.

If you cannot find CCC, you may need to change your graphics driver to a proprietary version.
To do this, go to system settings (power button in top right -> system settings), then click software and updates. Click the "additional drivers" tab and select one of AMD's proprietary drivers from there.
Once you have installed a new driver, open terminal and run "sudo apt-get update"

share|improve this answer
    
The problem is that the options to change my resolution from there, are greyed out on CCC. How am I supposed to fix this? –  Stel Jun 28 '13 at 6:09
    
That's why you have to open the administrative version first. Once you do that and put in your password, it should let you fiddle with the display settings. –  plaguedoctor Jun 28 '13 at 6:27
    
Okay, I used sudo amdcccle on terminal and managed to have access. But I can't find such a resolution option as 1680x1050. My options are only these:1600x1200 60.0 + 1400x1050 60.0* 1600x900 60.0 1280x1024 60.0 1440x900 59.9 1280x960 60.0 1366x768 59.8 1360x768 60.0 1280x800 59.8 1152x864 60.0 1280x768 59.9 1280x720 60.0 1024x768 60.0 1024x600 60.0 800x600 60.3 800x480 60.0 720x480 60.0 640x480 59.9 –  Stel Jun 28 '13 at 12:10
    
Just checked my CCC, and I do have a 1680x1050 option. Perhaps try updating CCC or using a different driver? Also, did you try using the button in CCC, within the display manager tab, to auto-detect resolution? –  plaguedoctor Jul 1 '13 at 3:54
    
I've tried everything but I can't find any way out. How am I supposed to update or use a different driver? –  Stel Jul 1 '13 at 8:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.