Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It just gets stuck on the black screen while loading its services.

It boots if I go into recovery mode then I select resume normal boot but it's very slow and the laptop fan goes crazy.

It works perfectly fine and fast from USB.

Any help?


I have an Nvidia GEFORCE GT555M and the notebook model is Asus N55S

Edit 2.

Does Ubuntu uses the Nvidia driver when I boot from USB or the open source drivers? If it uses the open source drivers, I would like to keep using those. everything works great from usb, it fails to boot after install and if I resume normal boot from recovery mode, it works but it is very slow and the fan goes nuts.

Also I see no Nvidia driver when I go into additional drivers tab, maybe that helps.

share|improve this question
could be the graphic driver. Do you have an nVidia card? – Dee Jun 27 '13 at 19:32
yes, I have a GEFORCE GT 555M. the notebook model is assus N55S – myefs Jun 28 '13 at 6:51

Open terminal and try

sudo apt-get install nvidia-current

Try this in graphics safe mode from recovery menu if your desktop doesn't load

then reboot

share|improve this answer
does the live usb version of ubuntu 13.04 uses Nvidia drivers? Everything works great from usb, it breaks when I install it. – myefs Jun 28 '13 at 13:02
nvidia-current drivers could be the problem part.. better to remove them completely to use standard linux drivers. see my response. – Dee Jun 29 '13 at 10:43

before you go to install something to Nvidia, try to completely remove nvidia drivers. there could be nvidia-kernel versions issues. Try this: sudo apt-get remove --purge nvidia-*, restart, sudo apt-get update.

after you will go with standard drivers. Then you can try to install additional drivers if they apear in your settings.

The fact Nvidia drivers are not present in additional drivers points on some settings problem. If this persist after removing/purge nvidia drivers followed by restart and apt-get update, try to find proper nvidia drivers on asian nvidia website (

Additionally, you can look into bios settings, some cards has an option to disable 3D. if this is the case do it temporary and see if this will help to solve your problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.