Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I changed the timer setting on GRUB to 0 seconds, this was accidental.

Now my computer boots straight into Windows 8 as this was my default GRUB option.

Since the GRUB menu no longer appears (as the delay is 0 seconds) I can't boot into Ubuntu.

Is there any way to change the GRUB settings from Windows OR boot into Ubuntu in another way?

Any help would be much appreciated.

Thanks

share|improve this question
    
I know this sounds simple, but have to held the down arrow before it is due to come on the screen? Otherwise you will need an application to view ext2/4 partitions in windows and edit the /etc/default/grub file from there. How to read Ext3/Ext4 linux partition from windows 7 –  BiggJJ Jun 27 '13 at 16:00
    
I did try holding the arrow key but unfortunately it didn't work. I'll have a go at viewing the partitions. –  user170732 Jun 27 '13 at 16:12
add comment

2 Answers 2

  1. Download Boot repair tool from the following link:http://sourceforge.net/projects/boot-repair-cd/files/
  2. Then burn it on CD or put it on USB key via Unetbootin.
  3. Insert the Boot-Repair-Disk and reboot the PC.
  4. Select Advanced option. There you can find boot menu timer option. Change as you like and apply.
  5. Shut down your computer and remove boot cd and start again.
share|improve this answer
    
Thanks for this, already managed to fix it though. This seems much simpler than what I did so I'll remember it incase I do it again, hopefully I don't though, hehe. –  user170732 Jun 27 '13 at 17:10
add comment

Just load up your Ubuntu CD/DVD and instead of installing, just choose the 'Try it out' option. You'll be able to edit the grub.cfg file on the partition you installed Ubuntu on and change the timeout.

Good luck!

share|improve this answer
    
Hi there! I did what you said and used the Try it now, and eventually managed to change the timeout by editing the grub.cfg by accessing it through terminal. It worked. So thanks for your help (telling me to log in via Trial version)! :) –  user170732 Jun 27 '13 at 17:08
    
@user68186 No, the answer is not wrong. The file name I listed was wrong. I told the OP to boot into a live environment and fix it that way. Downvoting was not necessary. A simple edit would've sufficed. –  muffinz Jun 27 '13 at 21:18
    
@user170732 You're welcome! :) –  muffinz Jun 27 '13 at 21:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.