Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can not write to any usb drives, hard drives or Flash. They mount fine and I can read off them but can't copy anything to them as it tells me I do not have permisions. My drives are formated from my mac as mac journald and the permissions are to let everyone read and write to them. from linux the permisions are "owner user#99" I have tried for weeks to figure this out and tried may things I found here on the site but nothing has worked. If you have any ideas please help, but you must be very specific as I am new to linux and it is very hard to understand all the terminal talk.

thanks carey

share|improve this question

1 Answer 1

You need to turn off journaling if you want to be able to read/write to it from Ubuntu. Ubuntu only has support for writing to non-journaled HFS+ volumes. Linux can read HFS+ volumes. It can also write to HFS+ volumes, but only if they're formatted without journaling.

On your Mac, you can do so from disk utility, or open terminal, and do:

diskutil disableJournal /Volumes/Macintosh HD

Then you can mount the partition on Ubuntu

sudo mount -t hfsplus /dev/sdax /media/mac

Complements of Z.Hossain

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.