Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I do this:

  1. Start "System Settings"
  2. "Network Settings"
  3. "Proxy"
  4. "Use proxy auto configuration URL"
  5. I paste my PAC URL into the new text field
  6. "Apply"
  7. I click anywhere ("Network Connections", "Overview", close button)
  8. I go back and the proxy settings are gone.

How I can make the proxy settings stick?

share|improve this question

1 Answer 1

I might be here completely wrong, but the proxy settings in Linux are stored in the http_proxy variable.. If that variable is set, then programs will use it as the settings..

For example, if one exports the variable:

   export http_proxy='http://username:password@proxy.address.com:8080'

and runs any programm requiring web, it should go through the proxy.

This does not answer your question though exactly (although if you place this line in your .bashrc file in your home, this might be a workaround for your problem).

I suppose you might need to extract the address/port from the pac file youself.. Access it from the browser and use the "save as" option..

share|improve this answer
    
Using http_proxy from the console works. But reconq and many other KDE applications use the proxy settings. –  Aaron Digulla Jun 27 '13 at 15:53
    
@aaron-digulla: again I am not 100% sure, but I'd put the export command into /etc/profile file. Your login shell will execute prior to launching the KDE environment for you, and any subsequent process will have to have this variable set.. –  arthur Jun 28 '13 at 12:35
    
of course, you could put the command into ~/.bash_profile file first to test it for yourself.. Let me know if this works for you –  arthur Jun 28 '13 at 12:36
    
I cannot tell, why on your system the settings are not set. I'd suggest to run the gnome-control-center as root. In my system setting the command line puts the following line into /etc/environment variable: http_proxy="bumblah:8080/"; this should be equivelent as doing the same thing with the gui –  arthur Jun 28 '13 at 12:59
    
I know how to solve the problem on the command line. I can use apt-get with my proxy without problems. But Muon doesn't work, for example. Note: I'm on KDE/Kubuntu; I just noticed that I forgot to add the tag. So Gnome settings doesn't help me. –  Aaron Digulla Jun 28 '13 at 14:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.