Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a Linux noob and could use a little help with an issue.

I am trying to achieve a very specific resolution and screen size (720x480 @ 59.94) for my headless Ubuntu 12.04.2-64 Desktop box with a nVidia GeForce 8400 GS card.

The machine is used primarily for ssh and the GUI (remotely). The restricted drivers have not worked for my situation. I have created and tried to change the xorg.conf file according to the man but I am not achieving the desired result. The edited xorg.conf file displays the desktop in the desired scale or resolution but the screen output always 1280x768. When I try and add DisplaySize 720 480 to the Monitor section it breaks the file and will not produce a desktop.

Here is the xorg.conf file:

Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
Screen      1  "Screen1" RightOf "Screen0"
Screen      2  "Screen2" RightOf "Screen1"
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Section "Files"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/X11/misc"
FontPath     "/usr/share/fonts/X11/cyrillic"
FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/Type1"
FontPath     "/usr/share/fonts/X11/100dpi"
FontPath     "/usr/share/fonts/X11/75dpi"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath     "built-ins"
EndSection

Section "Module"
Load  "glx"
Load  "record"
Load  "dri2"
Load  "dbe"
Load  "extmod"
Load  "dri"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option      "Protocol" "auto"
Option      "Device" "/dev/input/mice"
Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Monitor"
Identifier   "Monitor1"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Monitor"
Identifier   "Monitor2"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
    ### <percent>: "<f>%"
    ### [arg]: arg optional
    #Option     "SWcursor"              # [<bool>]
    #Option     "HWcursor"              # [<bool>]
    #Option     "NoAccel"               # [<bool>]
    #Option     "ShadowFB"              # [<bool>]
    #Option     "VideoKey"              # <i>
    #Option     "WrappedFB"             # [<bool>]
    #Option     "GLXVBlank"             # [<bool>]
    #Option     "ZaphodHeads"           # <str>
    #Option     "PageFlip"              # [<bool>]
Identifier  "Card0"
Driver      "nouveau"
BusID       "PCI:1:0:0"
EndSection

Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
    ### <percent>: "<f>%"
    ### [arg]: arg optional
    #Option     "ShadowFB"              # [<bool>]
    #Option     "Rotate"                # <str>
    #Option     "fbdev"                 # <str>
    #Option     "debug"                 # [<bool>]
Identifier  "Card1"
Driver      "fbdev"
BusID       "PCI:1:0:0"
EndSection

Section "Device"
    ### Available Driver options are:-
    ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
    ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
    ### <percent>: "<f>%"
    ### [arg]: arg optional
    #Option     "ShadowFB"              # [<bool>]
    #Option     "DefaultRefresh"        # [<bool>]
    #Option     "ModeSetClearScreen"    # [<bool>]
Identifier  "Card2"
Driver      "vesa"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     1
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     4
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     8
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     15
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     16
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device     "Card1"
Monitor    "Monitor1"
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     1
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     4
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     8
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     15
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     16
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device     "Card2"
Monitor    "Monitor2"
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     1
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     4
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     8
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     15
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     16
EndSubSection
SubSection "Display"
    Viewport   0 0
    Modes "720x480"
    Depth     24
EndSubSection
EndSection

xrandr prints this:

Screen 0: minimum 320 x 200, current 1280 x 768, maximum 8192 x 8192
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 1280x768+0+0 (normal left inverted right x axis y axis) 370mm x   222mm
   1280x768       60.0*+   49.9  
   1280x1024      60.0  
   1024x768       60.0  
   800x600        60.3  
   720x576        50.0  
   720x480        59.9  
   640x480        60.0  
VGA-1 disconnected (normal left inverted right x axis y axis)

Here is my Xorg.0.log file:

http://pastebin.com/u5fTe2Ks

Any help would be greatly appreciated!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I fixed this problem by changing the "Screen" section adding Virtual followed by the screen size under Modes in the xorg.conf file. Below is a link to my new working file.

http://pastebin.com/Xm8H7XeQ

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.