Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 64 bit whenever, i am giving following command in the teminal

dpkg -s kernel

or

dpkg -s kernel-headers

both the output shows kernel or kernel headers are not installed .. How to solve this issue?

I have already tried to install the same

using ,

sudo apt-get install linux-headers-$(uname -r)

but the problem is not solved.

I am new to Ubuntu .. Please help me

share|improve this question
3  
What is the real problem? What are you trying to do? –  ignis Jun 27 '13 at 13:32
    
Try sudo apt-get update before running the Kernel header command –  Mitch Jun 27 '13 at 13:32
    
i want to install Exata virutal interface on it .. For which it is prerequisite to install kernel and kernel header. In the manual it says try the following command: dpkg -s kernel or dpkg -s kernel-headers. if the output is none then install them first –  Subhajit Jun 28 '13 at 4:14
add comment

1 Answer

kernel headers are provided by linux-headers-$(uname -r)-generic packages. Run:

dpkg -l | grep linux-headers

to see the installed headers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.