Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I have upgraded my OS from 12.10 to 13.04, its working just fine.

I was not facing this problem till today but I am not able to connect to a particular WiFi from the morning. I have two WiFi here & I am able to connect to other one.

As for the WiFi, there is no issue as other persons who are using Window can connect with that just fine. How to resolve this problem I don't know?

Note - I have restarted the WiFi as well as the system two times to overcome this issue.

Edited for giving more info:

lspci

[full lspci output can be found in revision 2 of this post]
....
04:00.0 Network controller: Intel Corporation WiFi Link 5100
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 03)
....

sudo lshw -c network

  *-network               
       description: Wireless interface
       product: WiFi Link 5100
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlan0
       version: 00
       serial: 00:24:d6:43:c0:58
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.8.0-25-generic firmware=8.83.5.1 build 33692 ip=192.168.1.17 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:44 memory:f0500000-f0501fff
  *-network DISABLED
       description: Ethernet interface
       product: RTL8111/8168 PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 03
       serial: b8:ac:6f:68:08:6d
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168d-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:41 ioport:5000(size=256) memory:f0404000-f0404fff memory:f0400000-f0403fff memory:f0420000-f043ffff

dmesg

[ 2244.563918] wlan0: authenticate with 00:25:5e:17:6b:28
[ 2244.566162] wlan0: send auth to 00:25:5e:17:6b:28 (try 1/3)
[ 2244.768488] wlan0: send auth to 00:25:5e:17:6b:28 (try 2/3)
[ 2244.972143] wlan0: send auth to 00:25:5e:17:6b:28 (try 3/3)
[ 2245.175754] wlan0: authentication with 00:25:5e:17:6b:28 timed out
[ 2264.745062] wlan0: authenticate with 00:25:5e:17:6b:28
[ 2264.746376] wlan0: direct probe to 00:25:5e:17:6b:28 (try 1/3)
[ 2264.949654] wlan0: direct probe to 00:25:5e:17:6b:28 (try 2/3)
[ 2265.153340] wlan0: direct probe to 00:25:5e:17:6b:28 (try 3/3)
[ 2265.356923] wlan0: authentication with 00:25:5e:17:6b:28 timed out
share|improve this question
    
Change the wireless security scheme (WPA+PSK etc etc) in router. If that doesn't resolve issue post hardware details of the wi-fi card (lspci, sudo lshw -c network), also just after trying to reconnect post result of dmesg (just last few line where you see the networking activity) –  Web-E Jun 27 '13 at 12:06
    
@Web-E - I have edited the question with the information which you asked.. –  RajeevK Jun 27 '13 at 12:13
add comment

1 Answer

up vote 0 down vote accepted

Looks like this hardware has some problem with N configuration in wi-fi.

Please try:

    sudo modprobe -r iwlwifi
    sudo modprobe iwlwifi 11n_disable=1

Now try to reconnect, if it helps follow below steps

  1. Look into /etc/modprobe.d whether there are any file like intel-5100-iwlwifi-disable11n.conf then edit the file

    sudo gedit /etc/modprobe.d/<filename_here>

    Edit the line that says

    options iwlwifi 11n_disable=1
    

    to

    options iwlwifi 11n_disable=0
    

Save and reboot.

  1. If no file exists, create a new file

    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    

    Add a new line:

    options iwlwifi 11n_disable=1
    

Save and reboot.

Possibly related :

No Wireless N on Intel 5100

Wireless will not work with an Intel 5100 wireless card

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.