Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 10.04 64bit on a Dell Latitude E6400 laptop.

I want "None" under Visual Effects (on the Appearance Preferences), but when I reboot it reverts to Normal. I've tried uninstalling Compiz but that clearly upsets the gods because then I lose my title bars. Googling for help on this produces answers involving the Visual Effects option, which is all ghosted out once I've uninstall compiz. Not only that, but the keyboard is ignored in all windows unless only one window is open (actually, it might be just the window the mouse is currently over). So if I google for help and the answer it is to type something into Terminal, I cannot do this until I quit the browser.

I installed another instance of Ubuntu from the same CD, which is working fine.

It seems to me that something else is perhaps trying to load/use compiz it when I reboot, and if it's not there it has this title bar problem. There's nothing obvious in my "Startup Applications" list.

Edit: I just created another user, and for this user the desired setting sticks, suggesting it's a per-user setting/problem, not a system wide one.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Compiz Fusion Icon may be helpful.

Take a look at this: Emerald window decorator fails to start... sometimes., posted here for your convenience.

You can use Compiz Fusion Icon which can be easily installed by dropping sudo apt-get install fusion-icon in a terminal. After that, find the fusion-icon in the System Tools menu and you will have several choices in the panel's fusion icon, which includes but not limits to: Select Window Decorator.

Right click the fusion icon and choose your prefered window decorator, window manager and a few other features. Then select "Reload Window Manager" and your monitor or windows may flicker.

Don't worry, it will take just a moment to reload your options and after that you can close the fusion Icon. The options should persist this time.

A screenshot is placed here to illustrate.

Good luck!

enter image description here

Edit

Take a look at this: http://en.gentoo-wiki.com/wiki/Compiz-Fusion

If you are using Gnome, go to the Gnome's section, which is placed here for your convenience. enter image description here

With this logic in mind, just

To change the default window manager in gnome run gconf-editor, and set /desktop/gnome/session/required_components/windowmanager to "metacity"

The majority of the times, running metacity --replace is enough for the changes you wish, but if needed, run sudo metacity --replace and let's see what happens.

I hope this help.

share|improve this answer
    
Yeah, by doing and and sort of playing around I've got the windows minimizing/maximizing quickly, even if I can't actually select "none". I have to load that icon at each boot time, however, otherwise I can't alt-tab, ctrl-alt-left etc. I can't just revert back to whatever "window manager" I was using before I experimented with Compiz? Or is that Metacity? In which case why have I lost the shortcuts? There's nothing in the short-cut editor which tells me they're going to be ignored! –  Poldie Mar 21 '11 at 20:17
    
I edited my answer in order to give you a suggestion, I can't say why this happened to your system but I hope you find a solution. –  Geppettvs D'Constanzo Mar 21 '11 at 22:06
    
No, that's been great. What I learned from it was that you have to use fusion to "reload window manager" (without actually selecting a different one) then I can alt-tab etc. Or typing "metacity --replace" does the same thing, so I simply added that to my "startup applications" list and it's done the trick. –  Poldie Mar 22 '11 at 9:34

Try this:

  1. Press ALT + F2
  2. Type: metacity --replace (It will give compiz the blue pill)
  3. Go to System -> Preferences-> Appearance
  4. Go to Visual Effects tab and Select NONE.

The problem you have i sometimes have it if at the moment of changing to NONE am still using Compiz. Does not happen every time but when it does it happens exactly as you described.

Let me know if it helps since this is a most have answer for me and several students i have that want to join the Linux world.

share|improve this answer
    
Nope. I have to have compiz enabled to attempt the above, but when I reboot it's back to "normal" and not "none". –  Poldie Mar 21 '11 at 14:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.