Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried updating my ubuntu. All was going well until the last part of the installation using the update manager. It completed but with errors due to lack of space in my boot folder. It required a reboot and so I restarted it. After restarting the computer does not boot up. I used the previous version of my kernel3.2.0-35 generic and loaded fine.

I deleted all old and newer kernels (abi,system,vmlz) in the boot except the 3.2.0-35. I tried updating again but now it has unmet dependencies with the generic image kernel 3.2.0-37!

I can't do any apt-get install or update without getting errors.sudo apt-get -f install does not work and I cant get apt-get install synaptics to work due to the newer kernels it is asking for.

It seems the ubuntu is still working on the newest kernel even though in grub I select a previous version.

Any help will be Life-saving...:(

share|improve this question
    
apt-get update shouldn't be affected by missing dependencies or broken packages. Please edit your question to include the output of sudo apt-get update and sudo apt-get install linux-generic. –  Eric Carvalho Jun 27 '13 at 10:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.