Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.10 installed on my Asus G50VTX5. Sound works for the speakers but there's no sound from the headphones. Headphones are working fine in other devices.

share|improve this question
    
Headphone: Make and model? USB or plugged into sound card? –  arochester Mar 21 '11 at 12:45

5 Answers 5

up vote 1 down vote accepted

its an issue! I've opened a bug about this issue but canonical didnt give much attention. athough I've managed to put Headphones working

I've explained how to solve on page's bug report https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/660715

share|improve this answer

This is a pulseaudio bug, still present on 11.10

As a workaround edit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf :

gksu gedit analog-output-headphones.conf 

Than search for and comment this line like here:

[Jack_InputDevice]
#code = Headphone

Save the file and close gedit. Than restart pulseaudio with:

pulseaudio -k

Most people think this is an ALSA thing, but is not.

I reported this bug: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/921397

share|improve this answer

Open a terminal end type:

alsamixer

Play around with the bars. Use arrows to switch left-right or up/down to higher/lower the volume.

share|improve this answer

I wasn't able to edit the file and I struggled quite a bit trying to figure out why. I thought it was because of pixmap as I was getting an error message. I installed

sudo apt-get install gtk2-engines-pixbuf

error message was gone, but still not able to edit so I used the following command

gksudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

and there I was able to

I still get an error message everytime I save regarding a root file that does not exist, but it doesn't look like it's impeding the save process at all.

share|improve this answer

Your headphone output is probably muted. Open the sound control panel and check that you don't have any outputs muted.

share|improve this answer
    
Downvoted because?? I've had this problem, and it was exactly the case that my headphone output was muted. Not saying it's the answer every time, but worth checking. –  djeikyb Mar 28 '11 at 6:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.