Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'd have a fresh install of Ubuntu with tlp configured and using acpi_call to keep 7670M turned off.

I was a short time arch user and with openbox and firefox it was about 60 to 70 degrees; wanted to turn to a stable release just for this reason.

    acpitz-virtual-0
    Adapter: Virtual device
    temp1:        +50.0°C  

    radeon-pci-0100
    Adapter: PCI adapter
    temp1:       -128.0°C  

    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0:  +56.0°C  (high = +87.0°C, crit = +105.0°C)
    Core 0:         +54.0°C  (high = +87.0°C, crit = +105.0°C)
    Core 1:         +55.0°C  (high = +87.0°C, crit = +105.0°C)

The temperature is not seriously high yet can be lower.

Any suggestions?

Edit:

Surfing temps with one tab firefox:

    acpitz-virtual-0
    Adapter: Virtual device
    temp1:        +58.0°C  

    coretemp-isa-0000
    Adapter: ISA adapter
    Physical id 0:  +57.0°C  (high = +87.0°C, crit = +105.0°C)
    Core 0:         +55.0°C  (high = +87.0°C, crit = +105.0°C)
    Core 1:         +58.0°C  (high = +87.0°C, crit = +105.0°C)

Edit 2: Using a simple linux game get highten it to 70.

share|improve this question
1  
Good questions, but can you separate them into separate question entries? Too hard to answer in this form. –  belacqua Jun 26 '13 at 23:15
    
I just did, thanks. –  user170534 Jun 26 '13 at 23:19
2  
Install xfce instead of unity to disable the heavy use of compositing and your temp will drop. –  hbdgaf Jun 27 '13 at 0:27
1  
56 C is normal...what you can do is to use powersave on ac/bat with TLP, use indicator-cpufreq to change cpu frequency when you needed...use VA API if you are watching videos ( highly recommend ) ..askubuntu.com/questions/285434/… –  Qasim Jun 27 '13 at 0:28
    
Agreed, this is a normal temp. You can set up CPU throttling that will keep you CPU as a set temp, maybe worth a look Cool your CPU temperature with frequency throttling –  BiggJJ Jun 27 '13 at 0:40
show 1 more comment

1 Answer 1

  1. Run the command sudo cp /etc/default/grub /etc/default/grub.backup
  2. Run the command gksudo gedit /etc/default/grub
  3. Make sure you do not see noacpi (set it to acpi or delete it, depending on where it is), pci=noacpi (set it to pci=acpi), or acpi=off (set it to acpi=on)
  4. Reboot and see if it helps.

Basically, you set Ubuntu to use acpi to control the hardware, which generally fixes overheating. If your computer does not boot, revert /etc/default/grub to /etc/default/grub.backup.

share|improve this answer
    
there is no acpi in grub.cfg and I think tlp handles what you mean by control, but since I use acpi call that however, I think is on too. –  user170534 Jun 30 '13 at 6:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.