Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On a fresh install (13.04) I see a strange mix of languages in Software Center

enter image description here

The menu (like my system language) is in English, but the descriptions are in German. I want the descriptions in English too.

I am using a german keyboard and have German installed too (for giving support to students with German as system language :-))

In system settings I have moved German below English - so it should be ignored, I have logged out after that.

I have cleared the "Software Center Cache" with Ubuntu Tweak. The picture remains the same.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The Software Center doesn't store language settings for package information, but pulls them from apt. apt builds its backend based on the installation language. This has been reported as a bug.

If you have removed languages that you no longer need, you can reset the translations that apt-get looks for with:

sudo rm /var/lib/apt/lists/* -vf && sudo apt-get update

At least one person at the above-mentioned bug report, says the problem of apt showing package descriptions in a language that is now different from the one you are using was fixed by first choosing the language you need in Language Settings and then reinstalling the Software Center:

sudo apt-get --reinstall install software-center
share|improve this answer
    
The reinstall was needed. –  guntbert Jun 27 '13 at 11:15
    
@guntbert Glad it worked out. I edited my answer to clarify that. –  chaskes Jun 27 '13 at 15:54

My guess is that the system wide language is still German. May I suggest that you click the Apply system-wide button in Language Support and reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.