Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm just installed ubuntu 12.04 and was customizing my Main Menu using the standard application Ubuntu provides for that

enter image description here

and eliminated the entry Files it contained. Unfortunately this resulted not only in eliminating the entry for the main menu but also in uninstalling the default File Manager Canonical ships with ubuntu.

Fact is that now the only way to open a directory is to launch Nautilus via terminal. If I try to access it from the Places menu I'll be prompted with the following error:

enter image description here

As you can see the problem is that for some reason the File Manager is not registered any more for handling the directory files.

enter image description here

I looked for some file managers on the Ubuntu Software center and found a couple ones that helped me fix the problem,

enter image description here enter image description here

but none of these is the default one I was using before.

How can I restore the one I that was provided with the fresh install of Ubuntu?

share|improve this question
    
Take a look at the first answer to: askubuntu.com/questions/168752/… it may give you some pointers –  SimplySimon Jun 26 '13 at 16:39

3 Answers 3

You probably only edited the settings for your user, not system wide. If this is the case, a system wide reinstall of Nautilus will not help you solve your issue. All changes to the menu should be stored in the folder ~/.local/share/applications - check that folder if you find any file with "nautilus" or "files" in the name. Try to move this file to a different folder (in order to copy it back if it was the wrong one). In the worst case move all files from ~/.local/share/applications to a different location, and copy them back in, one by one, until you find the entry causing you troubles. It might be necessary to wait a few seconds for changes in that folder to apply, or you might even have to log out and back in again.

Also, there's a folder named ~/.local/share/mime/applications that contains file type association settings that have been changed from the system default.

share|improve this answer

Default file manager name is Nautilus. It is located in a package with same name. Just reinstall the package with apt-get. I think you are wrong in claiming that you have deleted it, however. It is protected as any Linux app is.

share|improve this answer

first install it to be able to purge.

    sudo apt-get install nautilus

Purging will help you remove the software as if it was never installed.

    sudo apt-get purge nautilus

Install it again, you may also want to clear your cache, just to be sure.

    sudo apt-get install nautilus

What I think the first problem was, in the settings of your desktop environment, find the place to choose default application for opening files. I do not know particular commands for every DE.

Then, I think you shall be fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.