Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question is in two parts, and I have been searching the web for days to find answers. With no luck I thought I'd drop by and ask for your help.

Here goes:

1.)

I'm running Ubuntu 13.04 and one day last week Unity suddenly wound't work. After the login screen, I was either faced with an all black and non-responsive screen, or sometimes it booted and I could see my desktop wallpaper (and add and remove icons/folders from the desktop). But there was no menu in the left hand side and no top bar :-( However I could still enter the terminal.

I borrowed my dad's laptop and looked for a solution online. About two days later I gave up (I'm still kind of a n00b at Linux) and found a way to install Gnome Fallback, via the terminal.

When I used it, I had the same problem. [clue #1] Missing menues. But if I rebooted into Gnome Fallback mode with no effects. It worked. Great!

I have used that for some days now, while still trying to fix the original problem with either Unity or OpenGl or whatever went wrong in the first place. With no luck.

After giving up on my search for a fix (I know that came out wrong) -- I decided to reinstall Ubuntu 13.04 from a CD.

But!

After that I was left where I began. When booting into my account, it only shows the desktop wallpaper and the icons. I can click and enter the folders, but not go into the menues.

Last time I fixed it with Gnome Fallback mode, because I could enter the terminal and the PC was automatically online, via wireless network.

But not this time, I can't get online.

So:

1.) How do I via the LiveCD Ubuntu version (the one I'm using right now) install Gnome Fallback unto the harddrive based system? 2.) If impossible. How can I access the wireless Internet via the terminal, so I can install Gnome Fallback, from the "broken" Unity session. 3.) Is there any other things that I should try?

Please help me,

PS: My GFX-card is an ATI Radeon something and I have install and used the "Redwood" drive (I think its called) for many weeks prior to the shutdown.

share|improve this question

2 Answers 2

Issues booting into a graphical shell usually are from missing, buggy or wrong drivers for our graphics card. To debug this we may boot into a shell with administrative rights and networking enabled as depicted here:

From there we can issue all commands from a command line, edit configuration files using a command line editor, update drivers, install or remove applications, and upgrade our distribution with bugfixes or security updates.

For installing the GNOME session fallback, after we had booted into a root shell with networking enabled we may issue the following commands:

# apt-get update # refreshes our aplications cache
# apt-get dist-upgrade # updates applications and the kernel
# apt-get install gnome-session-fallback # or any other application

Please be careful what you do in this root shell, because you are now root with the powers to do anything to your system even break it in case you made an error.

Please also note that in future releases GNOME session fallback will probably be called GNOME session flashback but it is at present uncertain how long this will be supported. So it will be a temporary solution only.

share|improve this answer
    
There is always GNOME Classic. –  fleamour Jun 26 '13 at 15:04
    
Thanks a lot for the very swift reply! But I'm still stuck. I have tried to enter three different kinds of kernal recovery modes, and it only worked one time. By that I mean I always get to the coloured menu, but only one time was I able to navigate the menu with my keyboard. The other times I couldn't go up and down in the menu. Anyway, the time it work I activated the network, it started loading and stuff, everything worked well. But then it stopped, and I couldn't go back to the colourd menu. :( Can I somehow fix it all via the LiveCD Ubuntu GUI or terminal? –  William Wind Jun 26 '13 at 15:24

O.k., here is how I fixed it:

After trying some of the above I simply gave up. Instead I downloaded Kubuntu 13.04 amd64 and installed it on a seperate partition. No problems at all.

Pros:

  • I can still access my files on the Ubuntu partition.
  • The GFX works better than ever. I can play Serious Sam 3, Oil Rush and Anomaly 2. I was unable to play those under my Ubuntu setup (don't know why, probably a faulty driver setup).

Cons:

  • I had to reinstall Steam and "lost" all my saved games.
  • I really like the Unity DE, so I have to get used to KDE.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.