Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't open bookmarks in new tabs from it (this seems to be a bug in Unity), so I disabled the add-on for it. But the latest update for Firefox (22.0) removed that add-on and re-enabled the global menu. How can I disable it again?

share|improve this question

1 Answer 1

up vote 9 down vote accepted

I just updated to Firefox 22.0 under Ubuntu 12.04 / Unity. The add-on is indeed gone.

There is a config setting that appears to disable the (tremendously annoying) global menus.

Open firefox.

Enter about:config in the address bar (like you're trying to go to that URL as a website).

Use the Search field to find the use_unity_menubar setting.

Right-click on it. Choose TOGGLE on the popup dialog. That should turn off the global menus and restore the top-of-window menus. (The full name of the preference is ui.use_unity_menubar.)

share|improve this answer
    
That fixed it. Thanks! –  Zelda64fan Jun 26 '13 at 15:42
    
My pleasure. Sure wish they would stop screwing around and use the 'standard' mechanism. I find the global menus very annoying and a hindrance to my productivity. –  Art Swri Jun 26 '13 at 15:47
    
Since I installed 12.04 two months ago this >exact< problem has been bugging me....I googled and googled and read post after post...until I tried the above solution. AAAhhhh...what a relief!!! Man, many thanks to both the asker and @Art Swri –  darbehdar Feb 5 at 6:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.