Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
[New Found!]
1. When I set to others instead of 1440x900 (16:10) or 1280x800 (16:10) revolutions,
   the black bar must disappear.

2. When I set to 1440x900 revolution, the black bar must exist.

The display area is not fit to my monitor(1440x900) and there is a black bar at the top of my screen. The bottom of the display area can't be displayed. How can I deal with this problem?

I wonder if the problem come from the lack of display card (MSI R4770 Cyclone) driver but I don't know how to install it. Do I need to install it?

Ubuntu Version : 13.10

Here are some related pictures :

My monitor (top)(It is a 19" desktop monitor. [Acer AL1916W]). enter image description here

My monitor (bottom) enter image description here

Displays enter image description here

xrandr enter image description here

There is no a file named as xorg.conf in X11. enter image description here

  *-display               
   description: VGA compatible controller
   product: RV740 PRO [Radeon HD 4770]
   vendor: Advanced Micro Devices, Inc. [AMD/ATI]
   physical id: 0
   bus info: pci@0000:01:00.0
   version: 00
   width: 64 bits
   clock: 33MHz
   capabilities: vga_controller bus_master cap_list rom
   configuration: driver=radeon latency=0
   resources: irq:43 memory:d0000000-dfffffff memory:feaf0000-feafffff      ioport:d000(size=256) memory:feac0000-feadffff
   WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Computer Information enter image description here enter image description here enter image description here


Anyone can help me solve this problem?

Thank you for your attention =]

share|improve this question
1  
So if I understand your question correctly, the workspace on your monitor has an offset downwards resulting in only a portion of the desktop being displayed? Does the resolution setting in Ubuntu match the one of your display (1440x900)? If not, make sure it is set correctly. How do you have your display connected? Analog/VGA/D-SUB cable or digitally (DVI/HDMI/DisplayPort)? If analog, have you tried recalibrating? (usually a button marked "auto" is present on your monitor) –  gertvdijk Jun 26 '13 at 15:14
    
The resolution setting in Ubuntu's display matchs the resolution of my display(1440x900). DVI+VGA –  Casper Li Jun 26 '13 at 15:36
    
From the photo it seems to be a laptop monitor, am I right? Also, have you tried with a LiveCD/DVD/USB? Does it work? –  Andrea Corbellini Nov 13 '13 at 18:14
    
Sorry, it is a 19" desktop monitor (Acer AL1916W). All the functions work well excluding display function. –  Casper Li Nov 14 '13 at 2:40

4 Answers 4

Sometimes the monitor itself requires some vertical/horizontal alignment via the buttons on the monitor (if it is a separate monitor); often there is an auto adjust button also that should do that for you.

Otherwise if this is not the problem, could you go into the terminal (CTRL + ALT + T) and type xrandr then press enter, and post the output here, and also the contents of the file /etc/X11/xorg.conf to give an idea of the configuration of your displays.

share|improve this answer
    
There is no a file named as xorg.conf in X11. Then, what can I do? Please tell me what to do. Thank You! –  Casper Li Nov 16 '13 at 6:16
    
Any other ideas? –  Casper Li Nov 17 '13 at 6:26

Looks like you'll have to adjust the vertical image offset of your monitor.

Your monitor should have some control buttons with menu options like brightness, contrast and image control among others. Search for the buttons around the edges of your monitor case; in mine it's alongside the power button.

With the menu button, select the image control/image adjust under which you'd find menus like auto adjust, horizontal position, vertical position, ...

MonitorMenu

Select vertical position and use the menu buttons (+,-) to adjust the vertical offset.

Checking your monitor's manual for details on your monitor settings might help.

share|improve this answer
    
The vertical position is already +100. It cannot be adjusted any longer. –  Casper Li Nov 17 '13 at 10:34
    
If you haven't already, try decreasing the value down from 100. Use - or < in the menu to decrease the value, probably to 50. –  precise Nov 17 '13 at 16:23
    
Try some of the other settings as well. –  Wilf Nov 17 '13 at 22:18
    
The problem appears again. I find something new. Please see the top of this post. Thank you. –  Casper Li Apr 29 at 11:57

Editing the monitor's configuration file may help - In your home directory, run:

gedit .config/monitors.xml

and see if changing the resolution helps.

To find if your graphics card has a driver, run this:

lshw -c display

and look for something like: configuration: driver=radeon latency=0

This is also possible by running:

lspci -v

and looking for: Kernel driver in use: radeon

under VGA compatible controller: ...

If you find anything, you could add the info to your question.

share|improve this answer
up vote 0 down vote accepted

Use the following setting can solve the problem. (turn off the second monitor) enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.