Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've run into a problem with sshfs that I haven't seen before.

I mount serverB to serverA by doing the following (while logged in as root on serverA):

mkdir serverBLink
sshfs root@serverB:/ /home/myname/Documents/serverBLink

Once I do that, from the commandline I'm able to see all the files on serverB via the serverBLink folder. Business as usual.

However, I cannot access the serverBLink folder using File Manager on Ubuntu. I don't know why. I thought it might be a permissions thing because I'm technically signed into the computer as "dot" but in the commandline, I've switched to root... ??

As a test I tried running chmod 777 on the serverBLink folder to grant everyone access to everything inside but it still doesn't work.

Using File Manager, when I try to access the serverBLink folder, I get the error message:

Could not enter folder

Any suggestions?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Maybe try -o allow_other to allow users other than the mounter to access.

Even better, you don't need to be root to use sshfs, so you can simply create the directory and mount the remote directory as yourself (but with root@serverB).

From a security perspective, you need to establish a connection as root@serverB (which you do already), and then you need at least execute permission on the mount directory and access to the mount contents itself.

share|improve this answer
    
I tried to use that switch. but i'm getting the error:fusermount: failed to open /etc/fuse.conf: Permission denied fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf. So i uncommented the user_allow_other line in the conf file but that still doesnt work –  dot Jun 26 '13 at 12:40
1  
Just mount as yourself then. It seems to be a default (and sensible) restriction. –  l0b0 Jun 26 '13 at 12:44
    
that worked. i removed the directory. recreated as myself. mounted as myself. works fine now. thanks –  dot Jun 26 '13 at 12:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.