Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a USB 3.0 AX88179 based Gigabit Ethernet adapter and after searching online, I found many people reporting success with this device under Linux. The driver entered the mainline kernel on version 3.9, but even before that, downloading the drivers from the the ASIX websites, compiling and loading the driver manually should work fine.

Unfortunately this is not the case for me on Ubuntu 12.10 and 13.04 on a Dell XPS 13 Developer Edition. I compile the driver (v1.4.0) without any problems (make, make install), I load it using modprobe and I see it as eth2. I can even see some RX/TX traffic but it cannot acquire an IP address so it is unusable.

dmesg output:

[ 1338.583575] ASIX USB Ethernet Adapter:v1.4.0 10:01:27 Jun 26 2013
[ 1338.583575]          http://www.asix.com.tw
[ 1338.583599] ax88179_178a 4-2:1.0 (unregistered net_device): mtu 1500
[ 1338.584080] ax88179_178a 4-2:1.0 eth0: register 'ax88179_178a' at usb-0000:00:14.0-2, ASIX AX88179 USB 3.0 Gigibit Ethernet, 00:24:9b:06:6a:85
[ 1338.585110] usbcore: registered new interface driver ax88179_178a
[ 1338.932157] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
[ 1338.933382] IPv6: ADDRCONF(NETDEV_UP): eth2: link is not ready
[ 1341.887977] ax88179_178a 4-2:1.0 eth2: ax88179_178a - Link status is: 1
[ 1341.889595] ax88179_178a 4-2:1.0 eth2: Write medium type: 0x013f
[ 1341.890699] IPv6: ADDRCONF(NETDEV_CHANGE): eth2: link becomes ready
[ 1341.891748] ax88179_178a 4-2:1.0 eth2: link up, 1000Mbps, full-duplex, lpa 0xC1E1

ifconfig output:

eth2      Link encap:Ethernet  HWaddr 00:24:9b:06:6a:85  
          inet6 addr: fe80::224:9bff:fe06:6a85/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:76623 errors:1 dropped:22802 overruns:0 frame:1
          TX packets:302 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2601276 (2.6 MB)  TX bytes:109741 (109.7 KB)

A different USB 2.0 Gigabit ethernet adapter and the WiFi are both working fine, so networking shouldn't be a problem on my laptop. Is there something I miss for this specific chipset?

FOLLOW UP

With the latest Kubuntu (and I guess Ubuntu as well) is working! So the problem is fixed. I guess it was a driver/kernel/hardware issue which is not present anymore with the latest kernel. I cannot tell the exact kernel version which made it to work, but for Trusty 14.04 everything looks fine!

share|improve this question
1  
It appears to be working "okay" from the output you provide, though it's dropping some frames. You could try to install a "mainline" 3.9 kernel as you suggest it would work with it. See How to update to kernel 3.8 rc7 Ubuntu 12.10 (but instead do the instructions for 3.9.7). –  gertvdijk Jun 26 '13 at 8:55
    
I tested without any luck :( –  Vangelis Tasoulas Jul 16 '13 at 8:43

2 Answers 2

This shouldn't be any different than manually compiling the driver as you've done, but other Ubuntu 12.04 precise users can use this ppa to easily install the driver:

It uses dkms to build asix's driver.

Step by step instructions:

sudo add-apt-repository ppa:qji/ax88179
sudo apt-get update
sudo apt-get install ax88179
share|improve this answer
    
I don't have Ubuntu Precise on my laptop. However, it looks like it might be some Dell XPS 13 related issue but I couldn't verify it myself after upgrading to the latest mainline kernel. Check also this thread: ubuntuforums.org/showthread.php?t=2089845&page=3 –  Vangelis Tasoulas Jul 16 '13 at 8:42
    
Thanks for joining the site to give this awesome answer. You should link to the source though (unless you're the author of the ppa?). –  Geoff Dec 30 '13 at 16:26

just in the case someone else arrives here....

yes, you are not getting an IPv4 address. and that's the only problem.

it is NOT a driver problem. the driver works just fine.

it's a configuration problem. you should be able to fix it editing the /etc/network/interfaces (i believe it's called the same on ubuntu...), telling it to use either a static ip or dhcp (more info on google); or, setting it (for static/dhcp) through your favorite network manager.

PS: sorry for the necro... I just arrived there and thought anyone who arrives here could use a solution.

share|improve this answer
    
That was not the case. Maybe it was not ONLY a driver problem, but a problem with the combination of the driver, Kernel and specific hardware I am using. A DHCP was present (that's why I wrote that it cannot acquire an IP) and I even tried to use a static IP. Also, I tried a different dongle and it was working. Anyway, now it is working with the latest Kubuntu so no matter what it was, it is now fixed! –  Vangelis Tasoulas May 14 at 21:54

protected by Community Oct 13 '13 at 7:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.