Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My VGN-SZ32CP laptop uses a NVIDIA GeForce Go 7400 GPU,but it seems that ubuntu does not detect it,like this:

dragon@dragon-VGN-SZ32CP-B:~$ lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML 
Express Integrated Graphics Controller (rev 03)

But only the cheap Intel card.Is there anybody who has the solution for it?

share|improve this question
1  
Is it activated in your bios? –  don.joey Jun 26 '13 at 8:19
    
@Private unfortunatly, the bios on the Sony laptops do not have much to configure, except the boot order! –  SimplySimon Jun 26 '13 at 8:42
1  
Welcome to Ask Ubuntu! Is this an Optimus-enabled laptop or does it have "simple" switchable graphics? Do you need a button or software in Windows to switch between graphics? I think this is one of the pre-Optimus Sony-specific implementations of switchable graphics. Do you have a function key to switch? Please provide the additional information in your question by editing it. –  gertvdijk Jun 26 '13 at 9:05
    
It looks like you are having a NVIDIA Optimus graphics solution. Take a look at the bumblebee project: bumblebee-project.org –  quidage Jun 26 '13 at 10:00
add comment

1 Answer 1

If you go to System Settings>Software and Updates>Additional Drivers

Screenshot

and select a different driver, this may help

If you can not see any drivers for NVIDIA here, go to the software centre and search for NVIDIA X.org 173 or just NVIDIA X.org and install one of these.

Make sure you tick the Optional Add-ons so that you get to edit your settings then run the first part again to see if there is a later version you can try.

share|improve this answer
2  
If lspci does not list the graphics card, then Ubuntu won't offer this driver, most likely - it's not detected at PCI-level. –  gertvdijk Jun 26 '13 at 9:03
    
hmmm. maybe not, I'll have a think... –  SimplySimon Jun 26 '13 at 9:10
    
@gertvdijk I have added a possible solution. –  SimplySimon Jun 26 '13 at 9:21
    
Hi,SimplySimon.I tried your way and it didn't work.I went to the place you went to,but there was nothing there.This laptop card had worked fine when I was using Ubuntu 10.10(the kernel 2.6),but when I switched to the 13.04(the kernel 3),it didn't work.I used other linux as well,but all the linux with kernels higher than 3.0 couldn't work.Do you have any ideas? –  dragon Jun 27 '13 at 12:23
    
I'm sorry, I am new at Linux and Ubuntu (just 2 months), and have no idea what you can do next, except to try looking and searching through previous questions and answers. –  SimplySimon Jun 27 '13 at 12:53
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.