Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting '4xxx Bus error core (dumped)' while trying to open sublime text by using this command

/usr/lib/sublime-text-2/sublime_text --class=sublime-text-2 "$@" . 

It was worked perfectly until yesterday. Any remedy for this. Do I need to re install my sublime?

share|improve this question
1  
I have the same issue(Arch). Try to downgrade glibc package, since gdb gives me 0xb7ff6b57 in memset () from /lib/ld-linux.so.2(ld-linux.so.2 refers to ld-2.17.so which is from glibc package). Unfortunately, I have a lot of dependencies from glibc-17, so, I can't downgrade it right now. –  soon Jun 26 '13 at 14:04
    
OK, downgrading from glibc-2.17-6 to glibc-2.17-2 doesn't solve the problem, and I can't downgrade more because of dependencies. Just replacing ld-2.17.so with ld-2.16.so doesn't work too. –  soon Jun 26 '13 at 14:56
add comment

1 Answer

The problem was with SublimeCodeIntel package. Just move(or remove) it outside of Packages folder:

mv <path to sublime-text>/Packages/SublimeCodeIntel ~/

Then run Sublime Text and re-install SublimeCodeIntel from PackageControl:

Ctrl+Shift+P -> Package Control: Install Package -> SublimeCodeIntel.

share|improve this answer
    
thanks @soon..for a minute I thought I lost my sublime text –  ManojGumber Jun 27 '13 at 10:59
    
@ManojGumber, Glad it helped :) –  soon Jun 27 '13 at 11:00
    
Thanks a lot for this answer! Worked like a charm. –  Pablo Lalloni Jun 27 '13 at 13:34
    
Actually, reinstalling didn't work at all for me, but at least it helped me to identify what was the source of the problem. I just uninstalled SublimeCodeIntel and goodbye segmentation faults:) –  Alter Lagos Aug 19 '13 at 22:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.