Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Ubuntu 13.04, and my Sansa Clip Zip MP3 player (uses USB) does not mount. I am new to Ubuntu so I'm not sure how to proceed when it says: unable to open device '[usb:001,011]'?

share|improve this question

According to this community entry you just need to go to "settings > system > usb mode" and select "MSC". Just do this in my player and it now visible in ubuntu.

Looks like MTP live in parallel to MSC so don't be confused when you will not see any files copied from Windows machine.

Version of firmware on my player is 1.1.20. There is a chance that you should update firmware to find usb option

share|improve this answer

the way you can automount your gadget is installing gvfs, using synaptic package manager or anyone else. most of the made-in-china stuff use mtp protocol, so you can mount it installing the addin suppoorting that

share|improve this answer

In addition to setting the player to MSC mode as described in the answer by Meta, you should try using another USB cable. I wouldn't believe it if I hadn't seen it myself, but when using a cable other than the short one that came with the player, it kept disconnecting.

share|improve this answer

What I did just now was going to "Settings" --> "System Settings" --> "USB Mode" --> "MTP"

If you do this, you will be able to see Sandisk as a USB device through your Ubuntu file manager (Nautilus, Thunar, etc.).

If you use the "MSC" mode, you will detect the device but cannot see the files inside "Music"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.