Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install 64-bit Ubuntu 13.04 on a Lenovo IdeaPad Y510p. This machine is pre-installed with Windows 8, which I want to keep (the machine is partly a game console).

I shrank the pre-installed Windows partition by 256GB to make space for Linux and booted from the Ubuntu install DVD. Initially there was a black screen issue, but adding 'nomodeset' to the kernel options fixed that. The install disc then booted into its normal Ubuntu environment. I selected "Install Ubuntu alongside Windows 8" and everything proceeded happily until it was time to pull the disc out and reboot.

At this point, both the F2 (full BIOS) and F12 (boot menu) startup menus display both "Windows 8" and "Ubuntu" as UEFI boot options, in addition to IPv4 and IPv6 network boot options. Windows 8 appears first, then Ubuntu, then network boot. So much is reasonable; the issue is that selecting Ubuntu boots the system into Windows.

Windows itself still boots fine. Disk Management reveals newly created 248.27GB and 7.73GB partitions in the formerly empty space, which I suppose to have been created by the Ubuntu installer; that seems fine. Following slangasek's comment here, I have not disabled Secure Boot or attempted to place the system in Legacy BIOS mode, since Secure Boot through UEFI is apparently supposed to work. But if there's a way to boot the Ubuntu install I just made, I can't find it.

Any advice?

share|improve this question
1  
As for your black screen issue, I've had the same problem when using the live CD and it turns out that the 'screen brightness' is just set to zero. If you're facing the same problem, hitting Fn+UpArrow should bring up your screen. –  user188571 Aug 29 '13 at 23:37
    
The fix with Fn + Up Arrow (on a black screen with the live CD) worked for me! (on Lenovo IdeaPad Y510p, Ubuntu 13.04 (Desktop)) –  Anton Petrov Sep 14 '13 at 10:17
    
hey ystael I have same laptop as you Ideapad y510p and I can't find the option to boot ubuntu dvd, in boot options menu i have windows network ipv4 and network ipv6. Is there a hidden option to boot on dvd or you must use a usb? secure boot is disabled. thanks –  vallllll Feb 6 at 0:34
add comment

1 Answer

up vote 2 down vote accepted

The first thing you should try is disabling Secure Boot -- but do not place the system in CSM/BIOS/legacy mode. The comments about Secure Boot that you reference are overly optimistic. In particular, although it does seem to work as planned for some systems, on others it most emphatically does not work as intended. If yours isn't working as intended, the symptoms would likely be precisely the ones you see. Thus, you should first try disabling Secure Boot. If it boots at that point, you can either leave Secure Boot disabled or try to fix it yourself. See my Web page on Secure Boot for more on this topic.

If disabling Secure Boot doesn't help, then I recommend you leave it disabled and try my rEFInd boot manager. You can try it without changing your disk configuration by using the USB flash drive or CD-R image; or you can install it from Windows. (If you do the latter, be sure that you install the driver for whatever filesystem you use on your Linux root (/) or /boot partition, though.) In a typical configuration that does not have a separate /boot partition, a rEFInd CD-R or USB flash drive should be able to boot either Linux or Windows directly and without further configuration. If you try rEFInd from an external disk and want to use it permanently, you can install it from either Windows or Linux.

share|improve this answer
1  
Sorry I left this answer unacknowledged for so long. Disabling Secure Boot does indeed allow me to select the Ubuntu UEFI bootloader from the BIOS menu, which gets me to GRUB. I seem to have a video driver problem which doesn't allow X to start, but that's a separate issue. Thanks! –  ystael Jul 13 '13 at 0:12
add comment

protected by Community Nov 21 '13 at 18:09

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.