Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Precise Pangolin on my MacBook Pro 9,1 provided by my work. Pretty much everything works great, except that when I close the lid and it suspends, the machine starts overheating. If I have the machine in my laptop bag, the fans will begin running as fast as possible, the machine will overheat very quickly and drain the battery.

What's more, the machine also hangs when I open the lid again to resume.

What's the deal here? I've had trouble finding other folks with the same problem.

share|improve this question
    
Does it get warm or do you think it overheats because the fans are running fast? Do you use the macfanctl daemon? Is it (the daemon) running? You can check this by typing "pstree | grep mac" in terminal. –  verpfeilt Jun 25 '13 at 17:58
    
I think that it's warm first and the fans kick in to deal with it, but there could be a sort of feedback loop where the fans are running, generating heat, and then spinning up faster to deal with it, thus creating even more heat. It appears that the macfanctl is running. How would I go about stopping that daemon? –  Newlin Jun 26 '13 at 20:11
    
Well I have only positive experience with macfanctl. It would be interesting to monitor processes when you close the lid. You could open a terminal and start "top" and close the lid, open it when it gets warm. Even if it hangs you may be able to see the culprit in the terminal on the top of the list that "top" creates. –  verpfeilt Jun 27 '13 at 13:13

1 Answer 1

I had these same problems with my MBP 9,1, but only with the nouveau graphics drivers and my discrete GPU.

I use GNOME, which has a setting for "Laptop lid, when closed, will suspend even if there is an external monitor plugged in" - turning this on let my machine sleep just fine. Unfortunately, I don't know if there's an analogue to this setting in other environments.

The hanging on wake got fixed when I installed the proprietary nVidia graphics drivers by running

jockey-text -e kmod:nvidia_313_updates

I've tried nvidia_310_updates and nvidia_313_updates, both worked.

Hope any of this helps, or that you've already got it working. I had a lot of trouble finding solutions when I was trying to get things working on this machine too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.